Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Program for creating simple man pages" |
| 2 | SECTION = "devel" |
| 3 | LICENSE = "GPLv3" |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 5 | DEPENDS = "autoconf-native automake-native" |
| 6 | |
| 7 | SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz" |
Andrew Geissler | 4ed12e1 | 2020-06-05 18:00:41 -0500 | [diff] [blame] | 8 | SRC_URI[sha256sum] = "c25a35b30eceb315361484b0ff1f81c924e8ee5c8881576f1ee762f001dbcd1c" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 9 | |
| 10 | inherit autotools native |
| 11 | |
| 12 | EXTRA_OECONF = "--disable-nls" |
| 13 | |
| 14 | # We don't want to reconfigure things as it would require 'perlnative' to be |
| 15 | # used. |
| 16 | do_configure() { |
| 17 | oe_runconf |
| 18 | } |
| 19 | |
| 20 | do_install_append () { |
| 21 | # Make sure we use /usr/bin/env perl |
| 22 | sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man |
| 23 | } |