blob: 8c11fb52e0f641a97b07d6c006193539dca0757b [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "GNOME editor"
2SECTION = "x11/gnome"
3LICENSE = "GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=75859989545e37968a99b631ef42722e"
5
6GNOMEBASEBUILDCLASS = "meson"
7
8DEPENDS = " \
9 gdk-pixbuf-native \
10 gtk+3 \
11 gsettings-desktop-schemas \
12 libpeas \
13 libsoup-2.4 \
14 gspell \
15 gtksourceview4 \
16 tepl \
17"
18
19inherit gnomebase gsettings itstool gnome-help gobject-introspection gtk-doc vala gettext features_check mime-xdg python3targetconfig
20
21def gnome_verdir(v):
22 return oe.utils.trim_version(v, 1)
23
24REQUIRED_DISTRO_FEATURES = "x11"
25
26SRC_URI[archive.sha256sum] = "7a9b18b158808d1892989165f3706c4f1a282979079ab7458a79d3c24ad4deb5"
27
28# gobject-introspection is mandatory and cannot be configured
29REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
30GIR_MESON_OPTION = ""
31
32GTKDOC_MESON_OPTION = "gtk_doc"
33
34PACKAGES += "${PN}-python"
35
36FILES:${PN} += " \
37 ${datadir}/dbus-1 \
38 ${datadir}/metainfo \
39"
40
41FILES:${PN}-python += " \
42 ${PYTHON_SITEPACKAGES_DIR} \
43"
44
45RDEPENDS:${PN} += "gsettings-desktop-schemas"
46RRECOMMENDS:${PN} += "source-code-pro-fonts"