blob: a0df05c9423d3bb302275b2c399cd6ba31982673 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Small collection of benchmarks for storage I/O"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b529aaa6a0c50f15d29f89609b5c22f3"
4
Brad Bishop2d39a062019-10-28 08:33:36 -04005SRCREV = "f97f1ae321d1fb8111a2c638075702ed2512ff07"
6PV = "3.6"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007SRC_URI = "git://github.com/Algodev-github/S.git;protocol=https;branch=master"
8
9S = "${WORKDIR}/git"
10
11# installing in /opt/S-suite since the package has
12# dependencies to the directory structure.
13do_install() {
14 install -d ${D}/opt/S-suite
15 for i in $(find ${S}/* -type d); do
16 install -d ${D}/opt/S-suite/$(basename $i)
17 install -m0755 -p ${S}/$(basename $i)/* ${D}/opt/S-suite/$(basename $i)
18 done
19
Brad Bishop19323692019-04-05 15:28:33 -040020 install -m0755 ${S}/def_config.sh ${D}/opt/S-suite
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021 install -m0755 ${S}/config_params.sh ${D}/opt/S-suite
Brad Bishop2f973922019-11-11 07:58:48 -050022 install -m0755 ${S}/create_config.sh ${D}/opt/S-suite
Brad Bishop19323692019-04-05 15:28:33 -040023 install -m0755 ${S}/process_config.sh ${D}/opt/S-suite
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080024}
25
Patrick Williams213cb262021-08-07 19:21:33 -050026RDEPENDS:${PN} = "bash bc coreutils gawk g++ gcc fio libaio libaio-dev sysstat \
Brad Bishop19323692019-04-05 15:28:33 -040027 git"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080028
Patrick Williams213cb262021-08-07 19:21:33 -050029FILES:${PN} = "/opt/S-suite/"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080030
31# added to INSANE_SKIP since s-suite have an runtime
32# dependency (RDEPENDS) on libaio-dev.
Patrick Williams213cb262021-08-07 19:21:33 -050033INSANE_SKIP:${PN} += "dev-deps"