blob: 0018064119f33cb214d5ae4df61c9cea842089e9 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "Concurrency Kit provides a plethora of concurrency primitives, \
2safe memory reclamation mechanisms and non-blocking data structures \
3designed to aid in the design and implementation of high performance \
4concurrent systems."
5
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "BSD-2-Clause & Apache-2.0"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05007HOMEPAGE = "http://concurrencykit.org"
8SECTION = "base"
9
10PV = "0.5.1+git${SRCPV}"
11SRCREV = "f97d3da5c375ac2fc5a9173cdd36cb828915a2e1"
12LIC_FILES_CHKSUM = "file://LICENSE;md5=a0b24c1a8f9ad516a297d055b0294231"
Andrew Geissler595f6302022-01-24 19:11:47 +000013SRC_URI = "git://github.com/concurrencykit/ck.git;branch=master;protocol=https \
Patrick Williamsb48b7b42016-08-17 15:04:38 -050014 file://cross.patch \
15"
16
17S = "${WORKDIR}/git"
18
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000019COMPATIBLE_HOST = "(arm|aarch64|i.86|x86_64|powerpc|powerpc64).*-linux*"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050020
21inherit autotools-brokensep
22
Patrick Williams213cb262021-08-07 19:21:33 -050023PLAT:powerpc64 = "ppc64"
24PLAT:powerpc64le = "ppc64"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050025PLAT ?= "${HOST_ARCH}"
26
27do_configure () {
28 export PLATFORM=${PLAT}
29 export COMPILER='gcc'
30 ${S}/configure \
31 --prefix=${prefix} \
32 --includedir=${includedir} \
33 --libdir=${libdir}
34}
35
36do_compile () {
37 oe_runmake
38}
39
40do_install () {
41 oe_runmake 'DESTDIR=${D}' install
42}