blob: 5b3b38d4a654b045829a95bed30cf209a2200c74 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001# SPDX-FileCopyrightText: Huawei Inc.
Andrew Geissler595f6302022-01-24 19:11:47 +00002#
Andrew Geisslereff27472021-10-29 15:35:00 -05003# SPDX-License-Identifier: MIT
4
Andrew Geisslereff27472021-10-29 15:35:00 -05005HOMEPAGE = "https://docs.lvgl.io"
6SUMMARY = "PNG decoder for LVGL"
7DESCRIPTION = "Allow the use of PNG images in LVGL. This implementation uses lodepng"
Andrew Geissler595f6302022-01-24 19:11:47 +00008LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=d6fc0df890c5270ef045981b516bb8f2"
10
11SRC_URI = "git://github.com/lvgl/lv_lib_png;destsuffix=${S};protocol=https;nobranch=1"
12SRCREV = "bf1531afe07c9f861107559e29ab8a2d83e4715a"
Andrew Geisslereff27472021-10-29 15:35:00 -050013
14# because of lvgl dependency
15REQUIRED_DISTRO_FEATURES = "wayland"
16
17DEPENDS += "lvgl"
18
19inherit cmake
20inherit features_check
21
22TARGET_CFLAGS += "-DLV_CONF_INCLUDE_SIMPLE=1"
23TARGET_CFLAGS += "-I${RECIPE_SYSROOT}/${includedir}/lvgl"
24
25FILES:${PN}-dev = "\
26 ${includedir}/lvgl/lv_lib_png/ \
27 "