blob: 2b8abb8b808b38b5c871c97defc2de33f9a688a1 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Wraps the best available JSON implementation available in a common interface"
2DESCRIPTION = "Anyjson loads whichever is the fastest JSON module installed and \
3provides a uniform API regardless of which JSON implementation is used."
4HOMEPAGE = "https://bitbucket.org/runeh/anyjson"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=989aa97e73c912a83a3c873fa11deb08"
7
Andrew Geisslerd221e032020-07-10 16:13:21 -05008inherit pypi setuptools3 ptest
9
10SRC_URI += " \
Andrew Geisslereff27472021-10-29 15:35:00 -050011 file://0001-setup.py-Do-not-use-2to3.patch \
Andrew Geisslerd221e032020-07-10 16:13:21 -050012 file://run-ptest \
13"
14
Patrick Williams213cb262021-08-07 19:21:33 -050015RDEPENDS:${PN}-ptest += " \
Andrew Geisslerd221e032020-07-10 16:13:21 -050016 ${PYTHON_PN}-pytest \
17 ${PYTHON_PN}-nose \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
Andrew Geissler82c905d2020-04-13 13:39:40 -050024
25SRC_URI[md5sum] = "2ea28d6ec311aeeebaf993cb3008b27c"
26SRC_URI[sha256sum] = "37812d863c9ad3e35c0734c42e0bf0320ce8c3bed82cd20ad54cb34d158157ba"
27
Patrick Williams213cb262021-08-07 19:21:33 -050028RDEPENDS:${PN} += "${PYTHON_PN}-simplejson"