blob: 8b3c8bbaaf59d3afa626fdd1c800d6eb6bc4956a [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Universal encoding detector for Python 2 and 3"
2LICENSE = "LGPL-2.1"
3LIC_FILES_CHKSUM = "file://LICENSE;md5=a6f89e2100d9b6cdffcea4f398e37343"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004
Andrew Geissler72956ed2021-01-08 16:11:14 -06005SRC_URI[sha256sum] = "0d6f53a15db4120f2b08c94f11e7d93d2c911ee118b6b30a04ec3ee8310179fa"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006
7# setup.py of chardet needs this.
8DEPENDS += "${PYTHON_PN}-pytest-runner-native"
9
10inherit pypi setuptools3
11
12PACKAGES =+ "${PN}-cli"
Patrick Williams213cb262021-08-07 19:21:33 -050013FILES:${PN}-cli += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050014 ${PYTHON_SITEPACKAGES_DIR}/chardet/cli \
15"
16
Patrick Williams213cb262021-08-07 19:21:33 -050017RDEPENDS:${PN}-cli = "${PN} "
Andrew Geissler82c905d2020-04-13 13:39:40 -050018
Patrick Williams213cb262021-08-07 19:21:33 -050019RDEPENDS:${PN}:class-target += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050020 ${PYTHON_PN}-logging \
21"
22
23BBCLASSEXTEND = "native nativesdk"