blob: 01343abc852e2f20a5b54e350237947a5b82af69 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "xxhash is a Python binding for the xxHash library by Yann Collet."
2SECTION = "devel/python"
3LICENSE = "BSD-2-Clause"
Andrew Geisslerf103a7f2021-05-07 16:09:40 -05004LIC_FILES_CHKSUM = "file://LICENSE;md5=3a9dab7f159514231249aa3e108ab26b"
Andrew Geissler82c905d2020-04-13 13:39:40 -05005
Andrew Geisslerf103a7f2021-05-07 16:09:40 -05006SRC_URI[sha256sum] = "b7bead8cf6210eadf9cecf356e17af794f57c0939a3d420a00d87ea652f87b49"
Andrew Geissler82c905d2020-04-13 13:39:40 -05007
8SRC_URI += " \
9 file://run-ptest \
10"
11
12inherit pypi setuptools3 ptest
13
Patrick Williams213cb262021-08-07 19:21:33 -050014RDEPENDS:${PN}-ptest += " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050015 ${PYTHON_PN}-pytest \
16"
17
18do_install_ptest() {
19 install -d ${D}${PTEST_PATH}/tests
20 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
21}