blob: 02038b0c12cd4eb083e6f076a60631a3a1166304 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Xfce4 Panel"
2SECTION = "x11"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=26a8bd75d8f8498bdbbe64a27791d4ee"
5DEPENDS = "garcon exo gtk+3 cairo virtual/libx11 libxml2 libwnck3 vala-native"
6
7inherit xfce gtk-doc gobject-introspection features_check remove-libtool mime-xdg
8
9REQUIRED_DISTRO_FEATURES = "x11"
10
William A. Kennington IIIb95905d2021-06-02 12:40:56 -070011SRC_URI[sha256sum] = "5934eaed8a76da52c29b734ccd79600255420333dd6ebd8fd9f066379af1e092"
Andrew Geissler82c905d2020-04-13 13:39:40 -050012SRC_URI += " \
13 file://0001-windowmenu-do-not-display-desktop-icon-when-no-windo.patch \
14 file://0002-use-lxdm-to-replace-dm-tool.patch \
15"
16
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000017EXTRA_OECONF += "--disable-vala"
18
Patrick Williams213cb262021-08-07 19:21:33 -050019python populate_packages:prepend() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050020 plugin_dir = d.expand('${libdir}/xfce4/panel/plugins/')
21 plugin_name = d.expand('${PN}-plugin-%s')
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000022 do_split_packages(d, plugin_dir, r'^lib(.*)\.so$', plugin_name,
Andrew Geissler82c905d2020-04-13 13:39:40 -050023 '${PN} plugin for %s', extra_depends='', prepend=True,
24 aux_files_pattern=['${datadir}/xfce4/panel/plugins/%s.desktop',
25 '${sysconfdir}/xdg/xfce/panel/%s-*',
26 '${datadir}/icons/hicolor/48x48/apps/*-%s.png',
27 '${bindir}/*%s*'])
28}
29
30PACKAGES_DYNAMIC += "^${PN}-plugin-.*"
31
32PACKAGES =+ "${PN}-gtk3"
33
Patrick Williams213cb262021-08-07 19:21:33 -050034FILES:${PN} += "${libdir}/xfce4/panel/migrate \
Andrew Geissler82c905d2020-04-13 13:39:40 -050035 ${libdir}/xfce4/panel/wrapper-1.0"
36
Patrick Williams213cb262021-08-07 19:21:33 -050037FILES:${PN}-dev += "${libdir}/xfce4/panel/plugins/*.la"
Andrew Geissler82c905d2020-04-13 13:39:40 -050038
Patrick Williams213cb262021-08-07 19:21:33 -050039FILES:${PN}-gtk3 = " \
Andrew Geissler82c905d2020-04-13 13:39:40 -050040 ${libdir}/libxfce4panel-2.0${SOLIBS} \
41 ${libdir}/xfce4/panel/wrapper-2.0 \
42"