blob: 7bf9feb0d60e86602037095daec9286196c6f563 [file] [log] [blame]
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05001# Inherit this class in recipes to enable building their introspection files
2
Patrick Williamsc0f7c042017-02-23 20:41:17 -06003# python3native is inherited to prevent introspection tools being run with
4# host's python 3 (they need to be run with native python 3)
5#
6# This also sets up autoconf-based recipes to build introspection data (or not),
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05007# depending on distro and machine features (see gobject-introspection-data class).
Patrick Williamsc0f7c042017-02-23 20:41:17 -06008inherit python3native gobject-introspection-data
Brad Bishopc342db32019-05-15 21:57:59 -04009
10# meson: default option name to enable/disable introspection. This matches most
11# project's configuration. In doubts - check meson_options.txt in project's
12# source path.
13GIR_MESON_OPTION ?= 'introspection'
14GIR_MESON_ENABLE_FLAG ?= 'true'
15GIR_MESON_DISABLE_FLAG ?= 'false'
16
Andrew Geissler595f6302022-01-24 19:11:47 +000017# Define g-i options such that they can be disabled completely when GIR_MESON_OPTION is empty
18GIRMESONTARGET = "-D${GIR_MESON_OPTION}=${@bb.utils.contains('GI_DATA_ENABLED', 'True', '${GIR_MESON_ENABLE_FLAG}', '${GIR_MESON_DISABLE_FLAG}', d)} "
19GIRMESONBUILD = "-D${GIR_MESON_OPTION}=${GIR_MESON_DISABLE_FLAG} "
Brad Bishopc342db32019-05-15 21:57:59 -040020# Auto enable/disable based on GI_DATA_ENABLED
Patrick Williams213cb262021-08-07 19:21:33 -050021EXTRA_OECONF:prepend:class-target = "${@bb.utils.contains('GI_DATA_ENABLED', 'True', '--enable-introspection', '--disable-introspection', d)} "
Andrew Geissler595f6302022-01-24 19:11:47 +000022EXTRA_OEMESON:prepend:class-target = "${@['', '${GIRMESONTARGET}'][d.getVar('GIR_MESON_OPTION') != '']}"
Patrick Williamsc0f7c042017-02-23 20:41:17 -060023# When building native recipes, disable introspection, as it is not necessary,
24# pulls in additional dependencies, and makes build times longer
Patrick Williams213cb262021-08-07 19:21:33 -050025EXTRA_OECONF:prepend:class-native = "--disable-introspection "
26EXTRA_OECONF:prepend:class-nativesdk = "--disable-introspection "
Andrew Geissler595f6302022-01-24 19:11:47 +000027EXTRA_OEMESON:prepend:class-native = "${@['', '${GIRMESONBUILD}'][d.getVar('GIR_MESON_OPTION') != '']}"
28EXTRA_OEMESON:prepend:class-nativesdk = "${@['', '${GIRMESONBUILD}'][d.getVar('GIR_MESON_OPTION') != '']}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050029
30# Generating introspection data depends on a combination of native and target
31# introspection tools, and qemu to run the target tools.
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000032DEPENDS:append:class-target = " gobject-introspection gobject-introspection-native qemu-native"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050033
Patrick Williamsc0f7c042017-02-23 20:41:17 -060034# Even though introspection is disabled on -native, gobject-introspection package is still
35# needed for m4 macros.
Patrick Williams213cb262021-08-07 19:21:33 -050036DEPENDS:append:class-native = " gobject-introspection-native"
37DEPENDS:append:class-nativesdk = " gobject-introspection-native"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050038
39# This is used by introspection tools to find .gir includes
Brad Bishop19323692019-04-05 15:28:33 -040040export XDG_DATA_DIRS = "${STAGING_DATADIR}:${STAGING_LIBDIR}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050041
Patrick Williams213cb262021-08-07 19:21:33 -050042do_configure:prepend:class-target () {
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050043 # introspection.m4 pre-packaged with upstream tarballs does not yet
44 # have our fixes
45 mkdir -p ${S}/m4
46 cp ${STAGING_DIR_TARGET}/${datadir}/aclocal/introspection.m4 ${S}/m4
47}
48
49# .typelib files are needed at runtime and so they go to the main package (so
50# they'll be together with libraries they support).
Patrick Williams213cb262021-08-07 19:21:33 -050051FILES:${PN}:append = " ${libdir}/girepository-*/*.typelib"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050052
53# .gir files go to dev package, as they're needed for developing (but not for
54# running) things that depends on introspection.
Patrick Williams213cb262021-08-07 19:21:33 -050055FILES:${PN}-dev:append = " ${datadir}/gir-*/*.gir ${libdir}/gir-*/*.gir"