blob: 6a9e862bcd770da5aa17d3ef2536582ce45c4d7b [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001UNINATIVE_LOADER ?= "${UNINATIVE_STAGING_DIR}-uninative/${BUILD_ARCH}-linux/lib/${@bb.utils.contains('BUILD_ARCH', 'x86_64', 'ld-linux-x86-64.so.2', '', d)}${@bb.utils.contains('BUILD_ARCH', 'i686', 'ld-linux.so.2', '', d)}${@bb.utils.contains('BUILD_ARCH', 'aarch64', 'ld-linux-aarch64.so.1', '', d)}${@bb.utils.contains('BUILD_ARCH', 'ppc64le', 'ld64.so.2', '', d)}"
Brad Bishop37a0e4d2017-12-04 01:01:44 -05002UNINATIVE_STAGING_DIR ?= "${STAGING_DIR}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05003
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05004UNINATIVE_URL ?= "unset"
Andrew Geissler595f6302022-01-24 19:11:47 +00005UNINATIVE_TARBALL ?= "${BUILD_ARCH}-nativesdk-libc-${UNINATIVE_VERSION}.tar.xz"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05006# Example checksums
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08007#UNINATIVE_CHECKSUM[aarch64] = "dead"
8#UNINATIVE_CHECKSUM[i686] = "dead"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -05009#UNINATIVE_CHECKSUM[x86_64] = "dead"
10UNINATIVE_DLDIR ?= "${DL_DIR}/uninative/"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050011
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000012# Enabling uninative will change the following variables so they need to go the parsing ignored variables list to prevent multiple recipe parsing
13BB_HASHCONFIG_IGNORE_VARS += "NATIVELSBSTRING SSTATEPOSTUNPACKFUNCS BUILD_LDFLAGS"
Brad Bishop316dfdd2018-06-25 12:45:53 -040014
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050015addhandler uninative_event_fetchloader
16uninative_event_fetchloader[eventmask] = "bb.event.BuildStarted"
17
18addhandler uninative_event_enable
19uninative_event_enable[eventmask] = "bb.event.ConfigParsed"
20
21python uninative_event_fetchloader() {
22 """
23 This event fires on the parent and will try to fetch the tarball if the
24 loader isn't already present.
25 """
26
Brad Bishop6e60e8b2018-02-01 10:27:11 -050027 chksum = d.getVarFlag("UNINATIVE_CHECKSUM", d.getVar("BUILD_ARCH"))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050028 if not chksum:
Brad Bishop6e60e8b2018-02-01 10:27:11 -050029 bb.fatal("Uninative selected but not configured correctly, please set UNINATIVE_CHECKSUM[%s]" % d.getVar("BUILD_ARCH"))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050030
Brad Bishop6e60e8b2018-02-01 10:27:11 -050031 loader = d.getVar("UNINATIVE_LOADER")
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050032 loaderchksum = loader + ".chksum"
33 if os.path.exists(loader) and os.path.exists(loaderchksum):
34 with open(loaderchksum, "r") as f:
35 readchksum = f.read().strip()
36 if readchksum == chksum:
37 return
38
39 import subprocess
40 try:
41 # Save and restore cwd as Fetch.download() does a chdir()
42 olddir = os.getcwd()
43
Brad Bishop6e60e8b2018-02-01 10:27:11 -050044 tarball = d.getVar("UNINATIVE_TARBALL")
45 tarballdir = os.path.join(d.getVar("UNINATIVE_DLDIR"), chksum)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050046 tarballpath = os.path.join(tarballdir, tarball)
47
Brad Bishop64c979e2019-11-04 13:55:29 -050048 if not os.path.exists(tarballpath + ".done"):
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050049 bb.utils.mkdirhier(tarballdir)
Brad Bishop6e60e8b2018-02-01 10:27:11 -050050 if d.getVar("UNINATIVE_URL") == "unset":
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050051 bb.fatal("Uninative selected but not configured, please set UNINATIVE_URL")
52
53 localdata = bb.data.createCopy(d)
54 localdata.setVar('FILESPATH', "")
55 localdata.setVar('DL_DIR', tarballdir)
Brad Bishopd7bf8c12018-02-25 22:55:05 -050056 # Our games with path manipulation of DL_DIR mean standard PREMIRRORS don't work
57 # and we can't easily put 'chksum' into the url path from a url parameter with
58 # the current fetcher url handling
Andrew Geissler635e0e42020-08-21 15:58:33 -050059 premirrors = bb.fetch2.mirror_from_string(localdata.getVar("PREMIRRORS"))
60 for line in premirrors:
61 try:
62 (find, replace) = line
63 except ValueError:
64 continue
65 if find.startswith("http"):
66 localdata.appendVar("PREMIRRORS", " ${UNINATIVE_URL}${UNINATIVE_TARBALL} %s/uninative/%s/${UNINATIVE_TARBALL}" % (replace, chksum))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050067
68 srcuri = d.expand("${UNINATIVE_URL}${UNINATIVE_TARBALL};sha256sum=%s" % chksum)
Andrew Geissler635e0e42020-08-21 15:58:33 -050069 bb.note("Fetching uninative binary shim %s (will check PREMIRRORS first)" % srcuri)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050070
71 fetcher = bb.fetch2.Fetch([srcuri], localdata, cache=False)
72 fetcher.download()
73 localpath = fetcher.localpath(srcuri)
74 if localpath != tarballpath and os.path.exists(localpath) and not os.path.exists(tarballpath):
Brad Bishopd7bf8c12018-02-25 22:55:05 -050075 # Follow the symlink behavior from the bitbake fetch2.
76 # This will cover the case where an existing symlink is broken
77 # as well as if there are two processes trying to create it
78 # at the same time.
79 if os.path.islink(tarballpath):
80 # Broken symbolic link
81 os.unlink(tarballpath)
82
83 # Deal with two processes trying to make symlink at once
84 try:
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050085 os.symlink(localpath, tarballpath)
Brad Bishopd7bf8c12018-02-25 22:55:05 -050086 except FileExistsError:
87 pass
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050088
Brad Bishop00111322018-04-01 22:23:53 -040089 # ldd output is "ldd (Ubuntu GLIBC 2.23-0ubuntu10) 2.23", extract last option from first line
90 glibcver = subprocess.check_output(["ldd", "--version"]).decode('utf-8').split('\n')[0].split()[-1]
91 if bb.utils.vercmp_string(d.getVar("UNINATIVE_MAXGLIBCVERSION"), glibcver) < 0:
Andrew Geisslerf0343792020-11-18 10:42:21 -060092 raise RuntimeError("Your host glibc version (%s) is newer than that in uninative (%s). Disabling uninative so that sstate is not corrupted." % (glibcver, d.getVar("UNINATIVE_MAXGLIBCVERSION")))
Brad Bishop00111322018-04-01 22:23:53 -040093
Brad Bishop6e60e8b2018-02-01 10:27:11 -050094 cmd = d.expand("\
95mkdir -p ${UNINATIVE_STAGING_DIR}-uninative; \
96cd ${UNINATIVE_STAGING_DIR}-uninative; \
Brad Bishop15ae2502019-06-18 21:44:24 -040097tar -xJf ${UNINATIVE_DLDIR}/%s/${UNINATIVE_TARBALL}; \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050098${UNINATIVE_STAGING_DIR}-uninative/relocate_sdk.py \
99 ${UNINATIVE_STAGING_DIR}-uninative/${BUILD_ARCH}-linux \
100 ${UNINATIVE_LOADER} \
101 ${UNINATIVE_LOADER} \
102 ${UNINATIVE_STAGING_DIR}-uninative/${BUILD_ARCH}-linux/${bindir_native}/patchelf-uninative \
Andrew Geisslerd159c7f2021-09-02 21:05:58 -0500103 ${UNINATIVE_STAGING_DIR}-uninative/${BUILD_ARCH}-linux${base_libdir_native}/libc*.so*" % chksum)
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500104 subprocess.check_output(cmd, shell=True)
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500105
106 with open(loaderchksum, "w") as f:
107 f.write(chksum)
108
109 enable_uninative(d)
110
Brad Bishop00111322018-04-01 22:23:53 -0400111 except RuntimeError as e:
112 bb.warn(str(e))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500113 except bb.fetch2.BBFetchException as exc:
114 bb.warn("Disabling uninative as unable to fetch uninative tarball: %s" % str(exc))
115 bb.warn("To build your own uninative loader, please bitbake uninative-tarball and set UNINATIVE_TARBALL appropriately.")
116 except subprocess.CalledProcessError as exc:
117 bb.warn("Disabling uninative as unable to install uninative tarball: %s" % str(exc))
118 bb.warn("To build your own uninative loader, please bitbake uninative-tarball and set UNINATIVE_TARBALL appropriately.")
119 finally:
120 os.chdir(olddir)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500121}
122
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500123python uninative_event_enable() {
124 """
125 This event handler is called in the workers and is responsible for setting
126 up uninative if a loader is found.
127 """
128 enable_uninative(d)
129}
130
131def enable_uninative(d):
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500132 loader = d.getVar("UNINATIVE_LOADER")
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500133 if os.path.exists(loader):
134 bb.debug(2, "Enabling uninative")
Brad Bishop37a0e4d2017-12-04 01:01:44 -0500135 d.setVar("NATIVELSBSTRING", "universal%s" % oe.utils.host_gcc_version(d))
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500136 d.appendVar("SSTATEPOSTUNPACKFUNCS", " uninative_changeinterp")
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500137 d.appendVarFlag("SSTATEPOSTUNPACKFUNCS", "vardepvalueexclude", "| uninative_changeinterp")
Brad Bishop316dfdd2018-06-25 12:45:53 -0400138 d.appendVar("BUILD_LDFLAGS", " -Wl,--allow-shlib-undefined -Wl,--dynamic-linker=${UNINATIVE_LOADER}")
139 d.appendVarFlag("BUILD_LDFLAGS", "vardepvalueexclude", "| -Wl,--allow-shlib-undefined -Wl,--dynamic-linker=${UNINATIVE_LOADER}")
140 d.appendVarFlag("BUILD_LDFLAGS", "vardepsexclude", "UNINATIVE_LOADER")
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500141 d.prependVar("PATH", "${STAGING_DIR}-uninative/${BUILD_ARCH}-linux${bindir_native}:")
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500142
143python uninative_changeinterp () {
144 import subprocess
145 import stat
146 import oe.qa
147
148 if not (bb.data.inherits_class('native', d) or bb.data.inherits_class('crosssdk', d) or bb.data.inherits_class('cross', d)):
149 return
150
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500151 sstateinst = d.getVar('SSTATE_INSTDIR')
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500152 for walkroot, dirs, files in os.walk(sstateinst):
153 for file in files:
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500154 if file.endswith(".so") or ".so." in file:
155 continue
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500156 f = os.path.join(walkroot, file)
157 if os.path.islink(f):
158 continue
159 s = os.stat(f)
160 if not ((s[stat.ST_MODE] & stat.S_IXUSR) or (s[stat.ST_MODE] & stat.S_IXGRP) or (s[stat.ST_MODE] & stat.S_IXOTH)):
161 continue
162 elf = oe.qa.ELFFile(f)
163 try:
164 elf.open()
Patrick Williamsd8c66bc2016-06-20 12:57:21 -0500165 except oe.qa.NotELFFileError:
166 continue
167 if not elf.isDynamic():
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500168 continue
169
Brad Bishop6e60e8b2018-02-01 10:27:11 -0500170 subprocess.check_output(("patchelf-uninative", "--set-interpreter", d.getVar("UNINATIVE_LOADER"), f), stderr=subprocess.STDOUT)
Patrick Williamsc124f4f2015-09-15 14:41:29 -0500171}