blob: ffaca4b58d906e1d1faa1e1e9d2b397f3f208072 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Initscript for enabling USB gadget Ethernet"
Brad Bishopa34c0302019-09-23 22:34:48 -04002DESCRIPTION = "This module allows ethernet emulation over USB, allowing for \
3all sorts of nifty things like SSH and NFS in one go plus charging over the \
4same wire, at higher speeds than most Wifi connections."
5HOMEPAGE = "http://linux-sunxi.org/USB_Gadget/Ethernet"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05006
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007LICENSE = "GPL-2.0-only"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05008LIC_FILES_CHKSUM = "file://${WORKDIR}/COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe"
9
10PR = "r3"
11
12SRC_URI = "file://usb-gether \
13 file://COPYING.GPL"
14S = "${WORKDIR}"
15
16do_install() {
17 install -d ${D}${sysconfdir}
18 install -d ${D}${sysconfdir}/init.d
19 install usb-gether ${D}${sysconfdir}/init.d
20}
21
22inherit update-rc.d allarch
23
24INITSCRIPT_NAME = "usb-gether"
25INITSCRIPT_PARAMS = "start 99 5 2 . stop 20 0 1 6 ."