blob: ab6ffe986c6c347bfc78e0403abfbb7f2f46e7b3 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SECTION = "console/network"
2SUMMARY = "dhcpcd - a DHCP client"
3DESCRIPTION = "dhcpcd runs on your machine and silently configures your \
4 computer to work on the attached networks without trouble \
5 and mostly without configuration."
6
7HOMEPAGE = "http://roy.marples.name/projects/dhcpcd/"
8
9LICENSE = "BSD-2-Clause"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=d148485768fe85b9f1072b186a7e9b4d"
11
12UPSTREAM_CHECK_URI = "https://roy.marples.name/downloads/dhcpcd/"
13
14SRC_URI = "https://roy.marples.name/downloads/${BPN}/${BPN}-${PV}.tar.xz \
15 file://0001-remove-INCLUDEDIR-to-prevent-build-issues.patch \
16 file://dhcpcd.service \
17 file://dhcpcd@.service \
18 "
19
20SRC_URI[sha256sum] = "819357634efed1ea5cf44ec01b24d3d3f8852fec8b4249925dcc5667c54e376c"
21
22inherit pkgconfig autotools-brokensep systemd useradd
23
24SYSTEMD_SERVICE:${PN} = "dhcpcd.service"
25
26PACKAGECONFIG ?= "udev ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
27
28PACKAGECONFIG[udev] = "--with-udev,--without-udev,udev,udev"
29PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6"
30# ntp conflicts with chrony
31PACKAGECONFIG[ntp] = "--with-hook=ntp, , ,ntp"
32PACKAGECONFIG[chrony] = "--with-hook=ntp, , ,chrony"
33PACKAGECONFIG[ypbind] = "--with-eghook=yp, , ,ypbind-mt"
34
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000035# add option to override DBDIR location
36DBDIR ?= "${localstatedir}/lib/${BPN}"
37
Andrew Geisslereff27472021-10-29 15:35:00 -050038EXTRA_OECONF = "--enable-ipv4 \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000039 --dbdir=${DBDIR} \
Andrew Geisslereff27472021-10-29 15:35:00 -050040 --sbindir=${base_sbindir} \
41 --runstatedir=/run \
42 --enable-privsep \
43 --privsepuser=dhcpcd \
44 --with-hooks \
45 --with-eghooks \
46 "
47
48USERADD_PACKAGES = "${PN}"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000049USERADD_PARAM:${PN} = "--system -d ${DBDIR} -M -s /bin/false -U dhcpcd"
Andrew Geisslereff27472021-10-29 15:35:00 -050050
51do_install:append () {
52 # install systemd unit files
53 install -d ${D}${systemd_system_unitdir}
54 install -m 0644 ${WORKDIR}/dhcpcd*.service ${D}${systemd_system_unitdir}
55
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000056 chmod 700 ${D}${DBDIR}
57 chown dhcpcd:dhcpcd ${D}${DBDIR}
Andrew Geisslereff27472021-10-29 15:35:00 -050058}
59
60FILES:${PN}-dbg += "${libdir}/dhcpcd/dev/.debug"