blob: a7939c9713d7892a6d4e23b42100c38ebf6a0ba8 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "XML C Parser Library and Toolkit"
2DESCRIPTION = "The XML Parser Library allows for manipulation of XML files. Libxml2 exports Push and Pull type parser interfaces for both XML and HTML. It can do DTD validation at parse time, on a parsed document instance or with an arbitrary DTD. Libxml2 includes complete XPath, XPointer and Xinclude implementations. It also has a SAX like interface, which is designed to be compatible with Expat."
3HOMEPAGE = "http://www.xmlsoft.org/"
4BUGTRACKER = "http://bugzilla.gnome.org/buglist.cgi?product=libxml2"
5SECTION = "libs"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://Copyright;md5=2044417e2e5006b65a8b9067b683fcf1 \
William A. Kennington IIIac69b482021-06-02 12:28:27 -07008 file://hash.c;beginline=6;endline=15;md5=e77f77b12cb69e203d8b4090a0eee879 \
9 file://list.c;beginline=4;endline=13;md5=b9c25b021ccaf287e50060602d20f3a7 \
10 file://trio.c;beginline=5;endline=14;md5=cd4f61e27f88c1d43df112966b1cd28f"
Andrew Geissler82c905d2020-04-13 13:39:40 -050011
12DEPENDS = "zlib virtual/libiconv"
13
14SRC_URI = "http://www.xmlsoft.org/sources/libxml2-${PV}.tar.gz;name=libtar \
15 http://www.w3.org/XML/Test/xmlts20080827.tar.gz;subdir=${BP};name=testtar \
16 file://libxml-64bit.patch \
17 file://runtest.patch \
18 file://run-ptest \
19 file://python-sitepackages-dir.patch \
20 file://libxml-m4-use-pkgconfig.patch \
21 file://0001-Make-ptest-run-the-python-tests-if-python-is-enabled.patch \
22 file://fix-execution-of-ptests.patch \
William A. Kennington IIIac69b482021-06-02 12:28:27 -070023 file://remove-fuzz-from-ptests.patch \
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000024 file://0002-Work-around-lxml-API-abuse.patch \
Andrew Geissler82c905d2020-04-13 13:39:40 -050025 "
26
William A. Kennington IIIac69b482021-06-02 12:28:27 -070027SRC_URI[libtar.sha256sum] = "c8d6681e38c56f172892c85ddc0852e1fd4b53b4209e7f4ebf17f7e2eae71d92"
Andrew Geissler82c905d2020-04-13 13:39:40 -050028SRC_URI[testtar.sha256sum] = "96151685cec997e1f9f3387e3626d61e6284d4d6e66e0e440c209286c03e9cc7"
29
30BINCONFIG = "${bindir}/xml2-config"
31
32PACKAGECONFIG ??= "python \
33 ${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} \
34"
35PACKAGECONFIG[python] = "--with-python=${PYTHON},--without-python,python3"
36PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
37
Andrew Geissler5a43b432020-06-13 10:46:56 -050038inherit autotools pkgconfig binconfig-disabled ptest
Andrew Geissler82c905d2020-04-13 13:39:40 -050039
Andrew Geisslereff27472021-10-29 15:35:00 -050040inherit ${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3targetconfig', '', d)}
Andrew Geissler82c905d2020-04-13 13:39:40 -050041
Patrick Williams213cb262021-08-07 19:21:33 -050042RDEPENDS:${PN}-ptest += "bash make ${@bb.utils.contains('PACKAGECONFIG', 'python', 'libgcc python3-core python3-logging python3-shell python3-stringold python3-threading python3-unittest ${PN}-python', '', d)}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050043
Patrick Williams213cb262021-08-07 19:21:33 -050044RDEPENDS:${PN}-python += "${@bb.utils.contains('PACKAGECONFIG', 'python', 'python3-core', '', d)}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050045
Patrick Williams213cb262021-08-07 19:21:33 -050046RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-gconv-ebcdic-us \
Andrew Geissler82c905d2020-04-13 13:39:40 -050047 glibc-gconv-ibm1141 \
48 glibc-gconv-iso8859-5 \
49 glibc-gconv-euc-jp \
50 locale-base-en-us \
51 "
52
53export PYTHON_SITE_PACKAGES="${PYTHON_SITEPACKAGES_DIR}"
54
55# WARNING: zlib is required for RPM use
56EXTRA_OECONF = "--without-debug --without-legacy --with-catalog --without-docbook --with-c14n --without-lzma --with-fexceptions"
Patrick Williams213cb262021-08-07 19:21:33 -050057EXTRA_OECONF:class-native = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
58EXTRA_OECONF:class-nativesdk = "--without-legacy --without-docbook --with-c14n --without-lzma --with-zlib"
59EXTRA_OECONF:linuxstdbase = "--with-debug --with-legacy --with-docbook --with-c14n --without-lzma --with-zlib"
Andrew Geissler82c905d2020-04-13 13:39:40 -050060
Patrick Williams213cb262021-08-07 19:21:33 -050061python populate_packages:prepend () {
Andrew Geissler82c905d2020-04-13 13:39:40 -050062 # autonamer would call this libxml2-2, but we don't want that
63 if d.getVar('DEBIAN_NAMES'):
Patrick Williams213cb262021-08-07 19:21:33 -050064 d.setVar('PKG:libxml2', '${MLPREFIX}libxml2')
Andrew Geissler82c905d2020-04-13 13:39:40 -050065}
66
67PACKAGE_BEFORE_PN += "${PN}-utils"
68PACKAGES += "${PN}-python"
69
Patrick Williams213cb262021-08-07 19:21:33 -050070FILES:${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*.a"
71FILES:${PN}-dev += "${libdir}/xml2Conf.sh"
72FILES:${PN}-utils = "${bindir}/*"
73FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050074
Patrick Williams213cb262021-08-07 19:21:33 -050075do_configure:prepend () {
Andrew Geissler82c905d2020-04-13 13:39:40 -050076 # executables take longer to package: these should not be executable
77 find ${S}/xmlconf/ -type f -exec chmod -x {} \+
78}
79
80do_compile_ptest() {
81 oe_runmake check-am
82}
83
84do_install_ptest () {
85 cp -r ${S}/xmlconf ${D}${PTEST_PATH}
86 if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then
87 sed -i -e 's|^\(PYTHON = \).*|\1${USRBINPATH}/${PYTHON_PN}|' \
88 ${D}${PTEST_PATH}/python/tests/Makefile
89 grep -lrZ '#!/usr/bin/python' ${D}${PTEST_PATH}/python |
90 xargs -0 sed -i -e 's|/usr/bin/python|${USRBINPATH}/${PYTHON_PN}|'
91 fi
92 #Remove build host references from various Makefiles
93 find "${D}${PTEST_PATH}" -name Makefile -type f -exec \
94 sed -i \
95 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
96 -e 's|${DEBUG_PREFIX_MAP}||g' \
97 -e 's:${HOSTTOOLS_DIR}/::g' \
98 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
99 -e 's:${RECIPE_SYSROOT}::g' \
100 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
101 -e '/^RELDATE/d' \
102 {} +
103}
104
Patrick Williams213cb262021-08-07 19:21:33 -0500105do_install:append:class-native () {
Andrew Geissler82c905d2020-04-13 13:39:40 -0500106 # Docs are not needed in the native case
107 rm ${D}${datadir}/gtk-doc -rf
108}
109
110BBCLASSEXTEND = "native nativesdk"