blob: 4df24c013befbdc08b932daad2bee1f5d3bddd7b [file] [log] [blame]
Brad Bishop96ff1982019-08-19 13:50:42 -04001# Copyright (C) 2019 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "A standalone library to implement GNU libc's obstack"
5DESCRIPTION = "copy + paste of the obstack functions and macros found in GNU gcc libiberty library for use with musl libc"
6HOMEPAGE = "https://github.com/pullmoll/musl-obstack"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00007LICENSE = "GPL-2.0-or-later"
Brad Bishop96ff1982019-08-19 13:50:42 -04008LIC_FILES_CHKSUM = "file://COPYING;md5=3d23e4eef8243efcaab6f0a438078932"
9SECTION = "libs"
10
11PV = "1.1"
12SRCREV = "d2ad66b0df44a4b784956f7f7f2717131ddc05f4"
Andrew Geissler595f6302022-01-24 19:11:47 +000013SRC_URI = "git://github.com/pullmoll/musl-obstack;branch=master;protocol=https"
Brad Bishop96ff1982019-08-19 13:50:42 -040014
15UPSTREAM_CHECK_COMMITS = "1"
16
17inherit autotools pkgconfig
18
19S = "${WORKDIR}/git"
20
21COMPATIBLE_HOST = ".*-musl.*"
22