blob: ee491984293f237d414543e38f4e24c2bcbee65f [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "manage symlinks in /etc/rcN.d"
2HOMEPAGE = "http://github.com/philb/update-rc.d/"
3DESCRIPTION = "update-rc.d is a utility that allows the management of symlinks to the initscripts in the /etc/rcN.d directory structure."
4SECTION = "base"
5
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00006LICENSE = "GPL-2.0-or-later"
Brad Bishopc8f47122019-06-24 09:36:18 -04007LIC_FILES_CHKSUM = "file://update-rc.d;beginline=5;endline=15;md5=d40a07c27f535425934bb5001f2037d9"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008
Andrew Geissler595f6302022-01-24 19:11:47 +00009SRC_URI = "git://git.yoctoproject.org/update-rc.d;branch=master"
Andrew Geissler5f350902021-07-23 13:09:54 -040010SRCREV = "8636cf478d426b568c1be11dbd9346f67e03adac"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080011
12UPSTREAM_CHECK_COMMITS = "1"
13
14S = "${WORKDIR}/git"
15
16inherit allarch
17
18do_compile() {
19}
20
21do_install() {
22 install -d ${D}${sbindir}
23 install -m 0755 ${S}/update-rc.d ${D}${sbindir}/update-rc.d
24}
25
26BBCLASSEXTEND = "native nativesdk"