blob: 5428c9ddf9fa4892bb26e44e23bab5c67f5e3f5d [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Perl module to manipulate and access URI strings"
2DESCRIPTION = "This package contains the URI.pm module with friends. \
3The module implements the URI class. URI objects can be used to access \
4and manipulate the various components that make up these strings."
5
6HOMEPAGE = "http://search.cpan.org/dist/URI/"
7SECTION = "libs"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008LICENSE = "Artistic-1.0 | GPL-1.0-or-later"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08009
10LIC_FILES_CHKSUM = "file://LICENSE;md5=c453e94fae672800f83bc1bd7a38b53f"
11
12DEPENDS += "perl"
13
14SRC_URI = "http://www.cpan.org/authors/id/E/ET/ETHER/URI-${PV}.tar.gz"
15
Andrew Geissler95ac1b82021-03-31 14:34:31 -050016SRC_URI[md5sum] = "cdbbf8f8ccdec5c162c8505077a35c2c"
17SRC_URI[sha256sum] = "7e2c6fe3b1d5947da334fa558a96e748aaa619213b85bcdce5b5347d4d26c46e"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
19S = "${WORKDIR}/URI-${PV}"
20
21EXTRA_CPANFLAGS = "EXPATLIBPATH=${STAGING_LIBDIR} EXPATINCPATH=${STAGING_INCDIR}"
22
23inherit cpan ptest-perl
24
25do_compile() {
26 export LIBC="$(find ${STAGING_DIR_TARGET}/${base_libdir}/ -name 'libc-*.so')"
27 cpan_do_compile
28}
29
Patrick Williams213cb262021-08-07 19:21:33 -050030do_install:prepend() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080031 # these tests require "-T" (taint) command line option
32 rm -rf ${B}/t/cwd.t
33 rm -rf ${B}/t/file.t
34}
35
Patrick Williams213cb262021-08-07 19:21:33 -050036RDEPENDS:${PN} += "perl-module-integer perl-module-mime-base64"
37RDEPENDS:${PN}-ptest += " \
Brad Bishop15ae2502019-06-18 21:44:24 -040038 libtest-needs-perl \
39 perl-module-test-more \
40 perl-module-test \
41 perl-module-utf8 \
42 perl-module-extutils-makemaker \
43 perl-module-net-domain \
44 perl-module-encode \
45 perl-module-extutils-mm-unix \
46 perl-module-file-spec-functions \
47 perl-module-perlio \
48"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080049
50BBCLASSEXTEND = "native"