blob: 1bec76bb2aaeb2dbcf9d1387f82bc2bfdec146be [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Arbitrary precision calculator language"
2HOMEPAGE = "http://www.gnu.org/software/bc/bc.html"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05003DESCRIPTION = "bc is an arbitrary precision numeric processing language. Syntax is similar to C, but differs in many substantial areas. It supports interactive execution of statements."
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00005LICENSE = "GPL-3.0-or-later"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08006LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
7 file://COPYING.LIB;md5=6a6a8e020838b23406c81b19c1d46df6 \
8 file://bc/bcdefs.h;endline=17;md5=4295c06df9e833519a342f7b5d43db06 \
9 file://dc/dc.h;endline=18;md5=36b8c600b63ee8c3aeade2764f6b2a4b \
10 file://lib/number.c;endline=20;md5=cf43068cc88f837731dc53240456cfaf"
11
12SECTION = "base"
13DEPENDS = "flex-native"
14
15SRC_URI = "${GNU_MIRROR}/${BPN}/${BP}.tar.gz \
16 file://no-gen-libmath.patch \
Brad Bishop96ff1982019-08-19 13:50:42 -040017 file://libmath.h \
18 file://0001-dc-fix-exit-code-of-q-command.patch"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019SRC_URI[md5sum] = "cda93857418655ea43590736fc3ca9fc"
20SRC_URI[sha256sum] = "62adfca89b0a1c0164c2cdca59ca210c1d44c3ffc46daf9931cf4942664cb02a"
21
22inherit autotools texinfo update-alternatives
23
24PACKAGECONFIG ??= "readline"
25PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
26PACKAGECONFIG[libedit] = "--with-libedit,--without-libedit,libedit"
27
Patrick Williams213cb262021-08-07 19:21:33 -050028do_compile:prepend() {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029 cp -f ${WORKDIR}/libmath.h ${B}/bc/libmath.h
30}
31
Patrick Williams213cb262021-08-07 19:21:33 -050032ALTERNATIVE:${PN} = "bc dc"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033ALTERNATIVE_PRIORITY = "100"
34
Brad Bishop15ae2502019-06-18 21:44:24 -040035BBCLASSEXTEND = "native"