blob: 430e481b36b6754b906eec56d13332b5862e3ac4 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "A library for text mode user interfaces"
2
3DESCRIPTION = "Newt is a programming library for color text mode, widget based user \
4interfaces. Newt can be used to add stacked windows, entry widgets, \
5checkboxes, radio buttons, labels, plain text fields, scrollbars, \
6etc., to text mode user interfaces. This package also contains the \
7shared library needed by programs built with newt, as well as a \
8/usr/bin/dialog replacement called whiptail. Newt is based on the \
9slang library."
10
11HOMEPAGE = "https://releases.pagure.org/newt/"
12SECTION = "libs"
13
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000014LICENSE = "LGPL-2.0-only"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050015LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
16
17# slang needs to be >= 2.2
Brad Bishopf3fd2882019-06-21 08:06:37 -040018DEPENDS = "slang popt python3"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019
20SRC_URI = "https://releases.pagure.org/newt/newt-${PV}.tar.gz \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050021 file://cross_ar.patch \
22 file://Makefile.in-Add-tinfo-library-to-the-linking-librari.patch \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050023 file://0001-detect-gold-as-GNU-linker-too.patch \
Andrew Geisslerc182c622020-05-15 14:13:32 -050024 file://0002-don-t-ignore-CFLAGS-when-building-snack.patch \
25 "
Brad Bishopd7bf8c12018-02-25 22:55:05 -050026
Brad Bishop08902b02019-08-20 09:16:51 -040027SRC_URI[md5sum] = "a0a5fd6b53bb167a65e15996b249ebb5"
28SRC_URI[sha256sum] = "265eb46b55d7eaeb887fca7a1d51fe115658882dfe148164b6c49fccac5abb31"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050029
30S = "${WORKDIR}/newt-${PV}"
31
Andrew Geisslereff27472021-10-29 15:35:00 -050032inherit autotools-brokensep python3native python3-dir python3targetconfig
Brad Bishopd7bf8c12018-02-25 22:55:05 -050033
Brad Bishopf3fd2882019-06-21 08:06:37 -040034EXTRA_OECONF = "--without-tcl --with-python"
35
36EXTRA_OEMAKE += "PYTHONVERS=${PYTHON_DIR}"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050037
38CLEANBROKEN = "1"
39
40export CPPFLAGS
41
Patrick Williams213cb262021-08-07 19:21:33 -050042PACKAGES:prepend = "whiptail ${PN}-python "
Brad Bishopf3fd2882019-06-21 08:06:37 -040043
Patrick Williams213cb262021-08-07 19:21:33 -050044RDEPENDS:${PN}-python += "python3-core"
45FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/*"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050046
Patrick Williams213cb262021-08-07 19:21:33 -050047do_configure:prepend() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050048 sh autogen.sh
49}
50
Patrick Williams213cb262021-08-07 19:21:33 -050051do_compile:prepend() {
Brad Bishopd7bf8c12018-02-25 22:55:05 -050052 # Make sure the recompile is OK
53 rm -f ${B}/.depend
54}
55
Patrick Williams213cb262021-08-07 19:21:33 -050056FILES:whiptail = "${bindir}/whiptail"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050057
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080058BBCLASSEXTEND = "native nativesdk"