blob: c41987d87c0bd7158102c5f141ba6073e35f7dd0 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Utilities for managing LZMA compressed files"
Andrew Geissler82c905d2020-04-13 13:39:40 -05002HOMEPAGE = "https://tukaani.org/xz/"
Andrew Geissler95ac1b82021-03-31 14:34:31 -05003DESCRIPTION = "XZ Utils is free general-purpose data compression software with a high compression ratio. XZ Utils were written for POSIX-like systems, but also work on some not-so-POSIX systems. XZ Utils are the successor to LZMA Utils."
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004SECTION = "base"
5
6# The source includes bits of PD, GPLv2, GPLv3, LGPLv2.1+, but the only file
7# which is GPLv3 is an m4 macro which isn't shipped in any of our packages,
8# and the LGPL bits are under lib/, which appears to be used for libgnu, which
9# appears to be used for DOS builds. So we're left with GPLv2+ and PD.
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000010LICENSE = "GPL-2.0-or-later & GPL-3.0-with-autoconf-exception & LGPL-2.1-or-later & PD"
11LICENSE:${PN} = "GPL-2.0-or-later"
12LICENSE:${PN}-dev = "GPL-2.0-or-later"
13LICENSE:${PN}-staticdev = "GPL-2.0-or-later"
14LICENSE:${PN}-doc = "GPL-2.0-or-later"
15LICENSE:${PN}-dbg = "GPL-2.0-or-later"
16LICENSE:${PN}-locale = "GPL-2.0-or-later"
Patrick Williams213cb262021-08-07 19:21:33 -050017LICENSE:liblzma = "PD"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080018
19LIC_FILES_CHKSUM = "file://COPYING;md5=97d554a32881fee0aa283d96e47cb24a \
20 file://COPYING.GPLv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
21 file://COPYING.GPLv3;md5=d32239bcb673463ab874e80d47fae504 \
22 file://COPYING.LGPLv2.1;md5=4fbd65380cdd255951079008b364516c \
23 file://lib/getopt.c;endline=23;md5=2069b0ee710572c03bb3114e4532cd84 \
24 "
25
Andrew Geissler82c905d2020-04-13 13:39:40 -050026SRC_URI = "https://tukaani.org/xz/xz-${PV}.tar.gz"
Andrew Geissler1e34c2d2020-05-29 16:02:59 -050027SRC_URI[md5sum] = "0d270c997aff29708c74d53f599ef717"
28SRC_URI[sha256sum] = "f6f4910fd033078738bd82bfba4f49219d03b17eb0794eb91efbae419f4aba10"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029UPSTREAM_CHECK_REGEX = "xz-(?P<pver>\d+(\.\d+)+)\.tar"
30
Andrew Geissler82c905d2020-04-13 13:39:40 -050031CACHED_CONFIGUREVARS += "gl_cv_posix_shell=/bin/sh"
32
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080033inherit autotools gettext
34
35PACKAGES =+ "liblzma"
36
Patrick Williams213cb262021-08-07 19:21:33 -050037FILES:liblzma = "${libdir}/liblzma*${SOLIBS}"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080038
39inherit update-alternatives
40ALTERNATIVE_PRIORITY = "100"
Patrick Williams213cb262021-08-07 19:21:33 -050041ALTERNATIVE:${PN} = "xz xzcat unxz \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080042 lzma lzcat unlzma"
43
44BBCLASSEXTEND = "native nativesdk"