blob: fcda10bd33aa31d6b426dc5cd051334d3ba6614a [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Middleware layer between GObject-using C libraries and language bindings"
2DESCRIPTION = "GObject Introspection is a project for providing machine \
3readable introspection data of the API of C libraries. This introspection \
4data can be used in several different use cases, for example automatic code \
5generation for bindings, API verification and documentation generation."
6HOMEPAGE = "https://wiki.gnome.org/action/show/Projects/GObjectIntrospection"
7BUGTRACKER = "https://gitlab.gnome.org/GNOME/gobject-introspection/issues"
8SECTION = "libs"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00009LICENSE = "LGPL-2.0-or-later & GPL-2.0-or-later & MIT"
Andrew Geisslereff27472021-10-29 15:35:00 -050010LIC_FILES_CHKSUM = "file://COPYING;md5=c434e8128a68bedd59b80b2ac1eb1c4a \
11 file://tools/compiler.c;endline=20;md5=fc5007fc20022720e6c0b0cdde41fabd \
12 file://giscanner/sourcescanner.c;endline=22;md5=194d6e0c1d00662f32d030ce44de8d39 \
13 file://girepository/giregisteredtypeinfo.c;endline=21;md5=661847611ae6979465415f31a759ba27 \
14 "
15
16SRC_URI = "${GNOME_MIRROR}/${BPN}/${@oe.utils.trim_version("${PV}", 2)}/${BPN}-${PV}.tar.xz \
Andrew Geissler595f6302022-01-24 19:11:47 +000017 file://0001-build-Avoid-the-doctemplates-hack.patch \
Andrew Geisslereff27472021-10-29 15:35:00 -050018 "
19
20SRC_URI[sha256sum] = "902b4906e3102d17aa2fcb6dad1c19971c70f2a82a159ddc4a94df73a3cafc4a"
21
22SRC_URI:append:class-native = " file://0001-Relocate-the-repository-directory-for-native-builds.patch"
23
24inherit meson pkgconfig gtk-doc python3native qemu gobject-introspection-data upstream-version-is-even multilib_script
25
26GTKDOC_MESON_OPTION = "gtk_doc"
27
28MULTILIB_SCRIPTS = "${PN}:${bindir}/g-ir-annotation-tool ${PN}:${bindir}/g-ir-scanner"
29
30DEPENDS += " libffi zlib glib-2.0 python3 flex-native bison-native autoconf-archive"
31
32# target build needs qemu to run temporary introspection binaries created
33# on the fly by g-ir-scanner and a native version of itself to run
34# native versions of its own tools during build.
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000035DEPENDS:append:class-target = " gobject-introspection-native qemu-native"
Andrew Geisslereff27472021-10-29 15:35:00 -050036
37# needed for writing out the qemu wrapper script
38export STAGING_DIR_HOST
39export B
40
41PACKAGECONFIG ?= ""
42PACKAGECONFIG[doctool] = "-Ddoctool=enabled,-Ddoctool=disabled,python3-mako,"
43
44# Configure target build to use native tools of itself and to use a qemu wrapper
45# and optionally to generate introspection data
46EXTRA_OEMESON:class-target = " \
47 -Dgi_cross_use_prebuilt_gi=true \
48 -Dgi_cross_binary_wrapper=${B}/g-ir-scanner-qemuwrapper \
49 -Dgi_cross_ldd_wrapper=${B}/g-ir-scanner-lddwrapper \
50 -Dgi_cross_pkgconfig_sysroot_path=${PKG_CONFIG_SYSROOT_DIR} \
51 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-Dbuild_introspection_data=true', '-Dbuild_introspection_data=false', d)} \
52 ${@'-Dgir_dir_prefix=${libdir}' if d.getVar('MULTILIBS') else ''} \
53"
54
Andrew Geisslereff27472021-10-29 15:35:00 -050055do_configure:prepend:class-native() {
56 # Tweak the native python scripts so that they don't refer to the
57 # full path of native python binary (the solution is taken from glib-2.0 recipe)
58 # This removes the risk of exceeding Linux kernel's shebang line limit (128 bytes)
59 sed -i -e '1s,#!.*,#!${USRBINPATH}/env python3,' ${S}/tools/g-ir-tool-template.in
60}
61
62do_configure:prepend:class-target() {
63 # Write out a qemu wrapper that will be given to gi-scanner so that it
64 # can run target helper binaries through that.
65 qemu_binary="${@qemu_wrapper_cmdline(d, '$STAGING_DIR_HOST', ['\\$GIR_EXTRA_LIBS_PATH','.libs','$STAGING_DIR_HOST/${libdir}','$STAGING_DIR_HOST/${base_libdir}'])}"
66 cat > ${B}/g-ir-scanner-qemuwrapper << EOF
67#!/bin/sh
68# Use a modules directory which doesn't exist so we don't load random things
69# which may then get deleted (or their dependencies) and potentially segfault
70export GIO_MODULE_DIR=${STAGING_LIBDIR}/gio/modules-dummy
71
72$qemu_binary "\$@"
73if [ \$? -ne 0 ]; then
74 echo "If the above error message is about missing .so libraries, then setting up GIR_EXTRA_LIBS_PATH in the recipe should help."
75 echo "(typically like this: GIR_EXTRA_LIBS_PATH=\"$""{B}/something/.libs\" )"
76 exit 1
77fi
78EOF
79 chmod +x ${B}/g-ir-scanner-qemuwrapper
80
81 # Write out a wrapper for g-ir-scanner itself, which will be used when building introspection files
82 # for glib-based packages. This wrapper calls the native version of the scanner, and tells it to use
83 # a qemu wrapper for running transient target binaries produced by the scanner, and an include directory
84 # from the target sysroot.
85 cat > ${B}/g-ir-scanner-wrapper << EOF
86#!/bin/sh
87# This prevents g-ir-scanner from writing cache data to user's HOME dir
88export GI_SCANNER_DISABLE_CACHE=1
89
90g-ir-scanner --lib-dirs-envvar=GIR_EXTRA_LIBS_PATH --use-binary-wrapper=${STAGING_BINDIR}/g-ir-scanner-qemuwrapper --use-ldd-wrapper=${STAGING_BINDIR}/g-ir-scanner-lddwrapper --add-include-path=${STAGING_DATADIR}/gir-1.0 --add-include-path=${STAGING_LIBDIR}/gir-1.0 "\$@"
91EOF
92 chmod +x ${B}/g-ir-scanner-wrapper
93
94 # Write out a wrapper for g-ir-compiler, which runs the target version of it through qemu.
95 # g-ir-compiler writes out the raw content of a C struct to disk, and therefore is architecture dependent.
96 cat > ${B}/g-ir-compiler-wrapper << EOF
97#!/bin/sh
98${STAGING_BINDIR}/g-ir-scanner-qemuwrapper ${STAGING_BINDIR}/g-ir-compiler "\$@"
99EOF
100 chmod +x ${B}/g-ir-compiler-wrapper
101
102 # Write out a wrapper to use instead of ldd, which does not work when a binary is built
103 # for a different architecture
104 cat > ${B}/g-ir-scanner-lddwrapper << EOF
105#!/bin/sh
Andrew Geissler7e0e3c02022-02-25 20:34:39 +0000106$OBJDUMP -p "\$@"
Andrew Geisslereff27472021-10-29 15:35:00 -0500107EOF
108 chmod +x ${B}/g-ir-scanner-lddwrapper
109
110 # Also tweak the target python scripts so that they don't refer to the
111 # native version of python binary (the solution is taken from glib-2.0 recipe)
112 sed -i -e '1s,#!.*,#!${USRBINPATH}/env python3,' ${S}/tools/g-ir-tool-template.in
113}
114
115do_compile:prepend() {
116 # This prevents g-ir-scanner from writing cache data to $HOME
117 export GI_SCANNER_DISABLE_CACHE=1
118
119 # Needed to run g-ir unit tests, which won't be able to find the built libraries otherwise
120 export GIR_EXTRA_LIBS_PATH=$B/.libs
121}
122
123do_install:prepend() {
124 # This prevents g-ir-scanner from writing cache data to $HOME
125 export GI_SCANNER_DISABLE_CACHE=1
126}
127
128# Our wrappers need to be available system-wide, because they will be used
129# to build introspection files for all other gobject-based packages
130do_install:append:class-target() {
131 install -d ${D}${bindir}/
132 install ${B}/g-ir-scanner-qemuwrapper ${D}${bindir}/
133 install ${B}/g-ir-scanner-wrapper ${D}${bindir}/
134 install ${B}/g-ir-compiler-wrapper ${D}${bindir}/
135 install ${B}/g-ir-scanner-lddwrapper ${D}${bindir}/
136}
137
138# we need target versions of introspection tools in sysroot so that they can be run via qemu
139# when building introspection files in other packages
140SYSROOT_DIRS:append:class-target = " ${bindir}"
141
142SYSROOT_PREPROCESS_FUNCS:append:class-target = " gi_binaries_sysroot_preprocess"
143gi_binaries_sysroot_preprocess() {
144 # Tweak the binary names in the introspection pkgconfig file, so that it
145 # picks up our wrappers which do the cross-compile and qemu magic.
146 sed -i \
147 -e "s|g_ir_scanner=.*|g_ir_scanner=${bindir}/g-ir-scanner-wrapper|" \
148 -e "s|g_ir_compiler=.*|g_ir_compiler=${bindir}/g-ir-compiler-wrapper|" \
149 ${SYSROOT_DESTDIR}${libdir}/pkgconfig/gobject-introspection-1.0.pc
150}
151
152SYSROOT_PREPROCESS_FUNCS:append = " gi_ldsoconf_sysroot_preprocess"
153gi_ldsoconf_sysroot_preprocess () {
154 mkdir -p ${SYSROOT_DESTDIR}${bindir}
155 dest=${SYSROOT_DESTDIR}${bindir}/postinst-ldsoconf-${PN}
156 echo "#!/bin/sh" > $dest
157 echo "mkdir -p ${STAGING_DIR_TARGET}${sysconfdir}" >> $dest
158 echo "echo ${base_libdir} >> ${STAGING_DIR_TARGET}${sysconfdir}/ld.so.conf" >> $dest
159 echo "echo ${libdir} >> ${STAGING_DIR_TARGET}${sysconfdir}/ld.so.conf" >> $dest
160 chmod 755 $dest
161}
162
163# Remove wrapper files from the package, only used for cross-compiling
164PACKAGE_PREPROCESS_FUNCS += "gi_package_preprocess"
165gi_package_preprocess() {
166 rm -f ${PKGD}${bindir}/g-ir-scanner-qemuwrapper
167 rm -f ${PKGD}${bindir}/g-ir-scanner-wrapper
168 rm -f ${PKGD}${bindir}/g-ir-compiler-wrapper
169 rm -f ${PKGD}${bindir}/g-ir-scanner-lddwrapper
170}
171
172SSTATE_SCAN_FILES += "g-ir-scanner-qemuwrapper g-ir-scanner-wrapper g-ir-compiler-wrapper g-ir-scanner-lddwrapper Gio-2.0.gir postinst-ldsoconf-${PN}"
173
174# .typelib files are needed at runtime and so they go to the main package
175FILES:${PN}:append = " ${libdir}/girepository-*/*.typelib"
176
177# .gir files go to dev package, as they're needed for developing (but not for running)
178# things that depends on introspection.
179FILES:${PN}-dev:append = " ${datadir}/gir-*/*.gir ${libdir}/gir-*/*.gir"
180FILES:${PN}-dev:append = " ${datadir}/gir-*/*.rnc"
181
182# These are used by gobject-based packages
183# to generate transient introspection binaries
184FILES:${PN}-dev:append = " ${datadir}/gobject-introspection-1.0/gdump.c \
185 ${datadir}/gobject-introspection-1.0/Makefile.introspection"
186
187# These are used by dependent packages (e.g. pygobject) to build their
188# testsuites.
189FILES:${PN}-dev:append = " ${datadir}/gobject-introspection-1.0/tests/*.c \
190 ${datadir}/gobject-introspection-1.0/tests/*.h"
191
192FILES:${PN}-dbg += "${libdir}/gobject-introspection/giscanner/.debug/"
193FILES:${PN}-staticdev += "${libdir}/gobject-introspection/giscanner/*.a"
194
195RDEPENDS:${PN} = "python3-pickle python3-xml"
196
197BBCLASSEXTEND = "native"