blob: 53c7254ce7e1c54cb52cab602266b1d5003bfaa0 [file] [log] [blame]
Andrew Geissler6ce62a22020-11-30 19:58:47 -06001DESCRIPTION = "The Vulkan Samples is collection of resources to help develop optimized Vulkan applications."
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002HOMEPAGE = "https://www.khronos.org/vulkan/"
3BUGTRACKER = "https://github.com/KhronosGroup/Vulkan-Samples/issues"
Andrew Geissler6ce62a22020-11-30 19:58:47 -06004LICENSE = "Apache-2.0"
5
6LIC_FILES_CHKSUM = "file://LICENSE;md5=48aa35cefb768436223a6e7f18dc2a2a"
7
Andrew Geissler595f6302022-01-24 19:11:47 +00008SRC_URI = "gitsm://github.com/KhronosGroup/Vulkan-Samples.git;branch=master;protocol=https \
Andrew Geissler6ce62a22020-11-30 19:58:47 -06009 file://0001-CMakeLists.txt-do-not-hardcode-lib-as-installation-t.patch \
Andrew Geisslerd1e89492021-02-12 15:35:20 -060010 file://debugfix.patch \
Andrew Geissler6ce62a22020-11-30 19:58:47 -060011 "
12
13UPSTREAM_CHECK_COMMITS = "1"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000014SRCREV = "28ca2dad83ceb157386e0708f5151ae89c177ad4"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060015
16UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for"
17S = "${WORKDIR}/git"
18
19REQUIRED_DISTRO_FEATURES = 'vulkan'
Andrew Geissler595f6302022-01-24 19:11:47 +000020COMPATIBLE_HOST = "(x86_64|aarch64|mips64|powerpc64|riscv64).*-linux"
Andrew Geissler6ce62a22020-11-30 19:58:47 -060021
22inherit cmake features_check
23
Patrick Williams213cb262021-08-07 19:21:33 -050024FILES:${PN} += "${datadir}"
Andrew Geisslerd1e89492021-02-12 15:35:20 -060025
26#
27# There is code to remove the prefix CMAKE_SOURCE_DIR from __FILENAME__ paths
28# used for logging with LOGE in the code. We need to make this match the value we use
29# in the debug source remapping from CFLAGS
30#
31EXTRA_OECMAKE += "-DCMAKE_DEBUG_SRCDIR=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}/"
32# Binaries built with PCH enabled don't appear reproducible, differing results were seen
33# from some builds depending on the point the PCH was compiled. Disable it to be
34# deterministic
35EXTRA_OECMAKE += "-DCMAKE_DISABLE_PRECOMPILE_HEADERS=ON"
Patrick Williams213cb262021-08-07 19:21:33 -050036
37# This needs to be specified explicitly to avoid xcb/xlib dependencies
38EXTRA_OECMAKE += "-DVKB_WSI_SELECTION=D2D"