blob: bba5e0450473fb75673b33e0414aed898058b5e3 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Generates traces of I/O traffic on block devices"
Andrew Geissler90fd73c2021-03-05 15:25:55 -06002DESCRIPTION = "blktrace is a block layer IO tracing mechanism which provides \
3detailed information about request queue operations up to user space. There \
4are three major components: a kernel component, a utility to record the i/o \
5trace information for the kernel to user space, and utilities to analyse and \
6view the trace information."
Brad Bishopd7bf8c12018-02-25 22:55:05 -05007HOMEPAGE = "http://brick.kernel.dk/snaps/"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00008LICENSE = "GPL-2.0-only"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05009LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
10
11DEPENDS = "libaio"
12
Andrew Geissler09036742021-06-25 14:25:14 -050013SRCREV = "366d30b9cdb20345c5d064af850d686da79b89eb"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050014
Andrew Geissler09036742021-06-25 14:25:14 -050015PV = "1.3.0+git${SRCPV}"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016
Andrew Geissler595f6302022-01-24 19:11:47 +000017SRC_URI = "git://git.kernel.dk/blktrace.git;branch=master"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050018
19S = "${WORKDIR}/git"
20
21EXTRA_OEMAKE = "\
22 'CC=${CC}' \
23 'CFLAGS=${CFLAGS}' \
24 'LDFLAGS=${LDFLAGS}' \
25"
26
27# There are a few parallel issues:
28# 1) ../rbtree.o: error adding symbols: Invalid operation
29# collect2: error: ld returned 1 exit status
30# Makefile:42: recipe for target 'btt' failed
31# 2) git/blkiomon.c:216: undefined reference to `rb_insert_color'
32# collect2: error: ld returned 1 exit status
33# Makefile:27: recipe for target 'blkparse' failed
34# 3) ld: rbtree.o: invalid string offset 128 >= 125 for section `.strtab'
35# 4) btreplay.o: file not recognized: File truncated
36# collect2: error: ld returned 1 exit status
37# btreplay/btreplay.c:47:18: fatal error: list.h: No such file or directory
38PARALLEL_MAKE = ""
39
40do_install() {
41 oe_runmake ARCH="${ARCH}" prefix=${prefix} \
42 mandir=${mandir} DESTDIR=${D} install
43}
44