blob: 04fc14a6d21f7fb83d0be43de1efe776fc6061f0 [file] [log] [blame]
Patrick Williamsc124f4f2015-09-15 14:41:29 -05001SUMMARY = "Wrapper script for the Linux kernel module dependency indexer"
2LICENSE = "MIT"
Patrick Williamsc124f4f2015-09-15 14:41:29 -05003
4S = "${WORKDIR}"
5
6INHIBIT_DEFAULT_DEPS = "1"
7# The kernel and the staging dir for it is machine specific
8PACKAGE_ARCH = "${MACHINE_ARCH}"
9
10# We need the following for the sstate code to process the wrapper
11SSTATE_SCAN_FILES += "depmodwrapper"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050012EXTRA_STAGING_FIXMES += "PKGDATA_DIR"
13
Brad Bishop316dfdd2018-06-25 12:45:53 -040014DEPENDS += "kmod-native"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015do_populate_sysroot[depends] = ""
Patrick Williamsc124f4f2015-09-15 14:41:29 -050016
17do_install() {
18 install -d ${D}${bindir_crossscripts}/
19
20 cat > ${D}${bindir_crossscripts}/depmodwrapper << EOF
21#!/bin/sh
22# Expected to be called as: depmodwrapper -a KERNEL_VERSION
23if [ "\$1" != "-a" -o "\$2" != "-b" ]; then
24 echo "Usage: depmodwrapper -a -b rootfs KERNEL_VERSION" >&2
25 exit 1
26fi
Brad Bishop316dfdd2018-06-25 12:45:53 -040027
28kernelabi=""
29if [ -r "${PKGDATA_DIR}/kernel-depmod/kernel-abiversion" ]; then
30 kernelabi=\$(cat "${PKGDATA_DIR}/kernel-depmod/kernel-abiversion")
Patrick Williamsc124f4f2015-09-15 14:41:29 -050031fi
32
Brad Bishop316dfdd2018-06-25 12:45:53 -040033if [ ! -r ${PKGDATA_DIR}/kernel-depmod/System.map-\$4 ] || [ "\$kernelabi" != "\$4" ]; then
Patrick Williamsc124f4f2015-09-15 14:41:29 -050034 echo "Unable to read: ${PKGDATA_DIR}/kernel-depmod/System.map-\$4" >&2
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000035 exec env depmod -C "\$3${sysconfdir}/depmod.d" "\$1" "\$2" "\$3" "\$4"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050036else
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000037 exec env depmod -C "\$3${sysconfdir}/depmod.d" "\$1" "\$2" "\$3" -F "${PKGDATA_DIR}/kernel-depmod/System.map-\$4" "\$4"
Patrick Williamsc124f4f2015-09-15 14:41:29 -050038fi
39EOF
40 chmod +x ${D}${bindir_crossscripts}/depmodwrapper
41}
42
Patrick Williamsc0f7c042017-02-23 20:41:17 -060043SYSROOT_DIRS += "${bindir_crossscripts}"
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050044
Brad Bishop316dfdd2018-06-25 12:45:53 -040045PACKAGES = ""
Patrick Williamsd8c66bc2016-06-20 12:57:21 -050046inherit nopackages