blob: 7bd6478d4c839be80e2fc58244dab6e9b4694931 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Interactive Connectivity Establishment library"
2DESCRIPTION = "Libnice is an implementation of the IETF's draft Interactive Connectivity Establishment standard (ICE)."
3HOMEPAGE = "http://nice.freedesktop.org/wiki/"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08004
5LICENSE = "LGPLv2.1 & MPLv1.1"
6LIC_FILES_CHKSUM = "file://COPYING;md5=9c42325015702feda4f4d2f19a55b767 \
7 file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \
8 file://COPYING.MPL;md5=3c617710e51cdbe0fc00716f056dfb1a \
9"
10
Brad Bishop7e36d532019-09-16 07:44:26 -040011SRC_URI = "http://nice.freedesktop.org/releases/libnice-${PV}.tar.gz"
12SRC_URI[md5sum] = "5ad936c43d3c6d33117b2c64982f2fd9"
13SRC_URI[sha256sum] = "06b678066f94dde595a4291588ed27acd085ee73775b8c4e8399e28c01eeefdf"
14
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080015DEPENDS = "glib-2.0 gnutls"
16
17PACKAGECONFIG ??= "gstreamer1.0"
18PACKAGECONFIG[gupnp] = "--enable-gupnp,--disable-gupnp,gupnp-igd"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080019PACKAGECONFIG[gstreamer1.0] = "--with-gstreamer,--without-gstreamer,gstreamer1.0 gstreamer1.0-plugins-base"
20
21inherit autotools pkgconfig gtk-doc gobject-introspection
22
Brad Bishop19323692019-04-05 15:28:33 -040023EXTRA_OECONF += "--without-gstreamer-0.10"
24
25FILES_${PN} += "${libdir}/gstreamer-1.0/*.so"
26FILES_${PN}-dev += "${libdir}/gstreamer-1.0/*.la"
27FILES_${PN}-staticdev += "${libdir}/gstreamer-1.0/*.a"
28FILES_${PN}-dbg += "${libdir}/gstreamer-1.0/.debug"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080029
30do_configure_prepend() {
31 mkdir ${S}/m4 || true
32}
33
34do_compile_append() {
35 for i in $(find ${B} -name "*.pc") ; do
36 sed -i -e s:${STAGING_DIR_TARGET}::g \
37 -e s:/${TARGET_SYS}::g \
38 $i
39 done
40}