blob: 5968d821346dff8b7e736ccd008a596e074fcb02 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001DESCRIPTION = "A simple memory benchmark program, which tries to measure the \
2peak bandwidth of sequential memory accesses and the latency of random memory \
3accesses. Bandwidth is measured by running different assembly code for the \
4aligned memory blocks and attempting different prefetch strategies"
5HOMEPAGE = "https://github.com/ssvb/tinymembench/wiki"
6LICENSE = "MIT"
7LIC_FILES_CHKSUM = "file://main.c;endline=22;md5=879b9bbb60851454885b5fa47eb6b345"
8
Patrick Williamsddad1a12017-02-23 20:36:32 -06009PV = "0.4.0+git${SRCPV}"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050010
Patrick Williamsddad1a12017-02-23 20:36:32 -060011SRCREV = "2c789849709d837b4bd114c11ed2d9bdc65afbc6"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050012SRC_URI = "git://github.com/ssvb/tinymembench.git"
13
14S = "${WORKDIR}/git"
15
Brad Bishop7f28bc52017-12-03 23:42:40 -050016TARGET_CC_ARCH += "${LDFLAGS}"
17
Patrick Williamsb48b7b42016-08-17 15:04:38 -050018do_install() {
19 install -d ${D}${bindir}
20 install -m755 tinymembench ${D}${bindir}/
21}
22
23# Fails to build with thumb-1 (qemuarm)
24#| {standard input}: Assembler messages:
25#| {standard input}:66: Error: instruction not supported in Thumb16 mode -- `subs r1,r1,#16'
26#| {standard input}:69: Error: instruction not supported in Thumb16 mode -- `subs r1,r1,#16'
27#| {standard input}:82: Error: selected processor does not support Thumb mode `mla r3,r4,r3,r5'
28#| {standard input}:82: Error: unshifted register required -- `and r8,r7,r3,lsr#16'
29ARM_INSTRUCTION_SET = "arm"