blob: 1abfc8819d916c441283ff763e4bcb0cc6688151 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Memory Efficient Serialization Library"
2HOMEPAGE = "https://github.com/google/flatbuffers"
3SECTION = "console/tools"
4LICENSE = "Apache-2.0"
5
6PACKAGE_BEFORE_PN = "${PN}-compiler"
7
8RDEPENDS_${PN}-compiler = "${PN}"
9RDEPENDS_${PN}-dev += "${PN}-compiler"
10
11LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
12
13SRCREV = "6df40a2471737b27271bdd9b900ab5f3aec746c7"
14
15SRC_URI = "git://github.com/google/flatbuffers.git"
16
Andrew Geissler7f40b712020-05-15 14:09:53 -050017CXXFLAGS += "-fPIC"
18BUILD_CXXFLAGS += "-fPIC"
Andrew Geissler82c905d2020-04-13 13:39:40 -050019
20# BUILD_TYPE=Release is required, otherwise flatc is not installed
21EXTRA_OECMAKE += "\
22 -DCMAKE_BUILD_TYPE=Release \
23 -DFLATBUFFERS_BUILD_TESTS=OFF \
24 -DFLATBUFFERS_BUILD_SHAREDLIB=ON \
25"
26
27inherit cmake
28
29S = "${WORKDIR}/git"
30
31FILES_${PN}-compiler = "${bindir}"
32
33BBCLASSEXTEND = "native nativesdk"