blob: aed5ce4dce3ca5acb46b79d8ede0fe4ca4f29545 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Easily themable notification daemon with transparency effects"
2HOMEPAGE = "http://goodies.xfce.org/projects/applications/xfce4-notifyd"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
5DEPENDS = " \
6 dbus \
7 dbus-glib \
8 libnotify \
9 libxfce4util \
10 libxfce4ui \
11 xfconf \
12 xfce4-panel \
13"
14
15inherit xfce-app
16
Andrew Geissler7f40b712020-05-15 14:09:53 -050017SRC_URI[md5sum] = "58e70621d6b9e0e66399ed41ab402a47"
18SRC_URI[sha256sum] = "9b5274999c89bf296a7de03b375e8233eef37940b7444502130b92dfb6a089b4"
Andrew Geissler82c905d2020-04-13 13:39:40 -050019
20# Avoid trouble with other desktops e.g KDE which also ships dbus service named
21# org.freedesktop.Notifications
22EXTRA_OECONF = "--disable-dbus-start-daemon"
23
24do_compile_prepend() {
25 mkdir -p xfce4-notifyd xfce4-notifyd-config
26}
27
28FILES_${PN} += " \
29 ${systemd_user_unitdir} \
30 ${datadir}/xfce4 \
31 ${datadir}/themes \
32 ${datadir}/dbus-1 \
33 ${libdir}/xfce4 \
34"