blob: 7b7b3929b38af607e7803aa78649867c11ca87a6 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Power usage tool"
2DESCRIPTION = "Linux tool to diagnose issues with power consumption and power management."
Andrew Geissler82c905d2020-04-13 13:39:40 -05003HOMEPAGE = "https://01.org/powertop/"
4BUGTRACKER = "https://app.devzing.com/powertopbugs/bugzilla"
Brad Bishop19323692019-04-05 15:28:33 -04005DEPENDS = "ncurses libnl pciutils"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
8
Andrew Geissler82c905d2020-04-13 13:39:40 -05009SRC_URI = "https://01.org/sites/default/files/downloads/powertop-v${PV}.tar.gz \
Brad Bishop08902b02019-08-20 09:16:51 -040010 file://0001-wakeup_xxx.h-include-limits.h.patch \
Brad Bishop19323692019-04-05 15:28:33 -040011"
12
13SRC_URI[md5sum] = "a69bd55901cf919cc564187402ea2c9c"
14SRC_URI[sha256sum] = "d3b7459eaba7d01c8841dd33a3b4d369416c01e9bd8951b0d88234cf18fe4a75"
15
16UPSTREAM_CHECK_URI = "https://01.org/powertop/downloads"
17UPSTREAM_CHECK_REGEX = "powertop-[v]?(?P<pver>\d+(\.\d+)+)\.tar"
18
19inherit autotools gettext pkgconfig
20
21S = "${WORKDIR}/${BPN}-v${PV}"
22
23# we do not want libncursesw if we can
24do_configure_prepend() {
25 # configure.ac checks for delwin() in "ncursesw ncurses" so let's drop first one
26 sed -i -e "s/ncursesw//g" ${S}/configure.ac
27 mkdir -p ${B}/src/tuning/
28}
29
30inherit update-alternatives
31ALTERNATIVE_${PN} = "powertop"
32ALTERNATIVE_TARGET[powertop] = "${sbindir}/powertop"
33ALTERNATIVE_LINK_NAME[powertop] = "${sbindir}/powertop"
34ALTERNATIVE_PRIORITY = "100"