blob: 2d087f6767a9980c032d000e474b4e3926e9ce5a [file] [log] [blame]
Patrick Venture6dd5cc92018-11-09 18:27:28 -08001HOMEPAGE = "http://github.com/openbmc/phosphor-ipmi-flash"
2SUMMARY = "Phosphor OEM IPMI In-band Firmware Update over BLOB"
3DESCRIPTION = "This package handles a series of OEM IPMI commands that implement the firmware update handler over the BLOB protocol."
4PR = "r1"
5PV = "0.1+git${SRCPV}"
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
8
9inherit autotools pkgconfig
10inherit obmc-phosphor-ipmiprovider-symlink
11
12DEPENDS += "autoconf-archive-native"
13DEPENDS += "phosphor-ipmi-blobs"
14DEPENDS += "phosphor-logging"
15DEPENDS += "sdbusplus"
16
17S = "${WORKDIR}/git"
18SRC_URI = "git://github.com/openbmc/phosphor-ipmi-flash"
Andrew Geisslerf6777bb2019-01-16 00:11:55 +000019SRCREV = "182b76491f74c9c24847eb08c14c7a64629636e8"
Patrick Venture6dd5cc92018-11-09 18:27:28 -080020
21FILES_${PN}_append = " ${libdir}/ipmid-providers/lib*${SOLIBS}"
22FILES_${PN}_append = " ${libdir}/blob-ipmid/lib*${SOLIBS}"
23FILES_${PN}-dev_append = " ${libdir}/ipmid-providers/lib*${SOLIBSDEV} ${libdir}/ipmid-providers/*.la"
24
25BLOBIPMI_PROVIDER_LIBRARY += "libfirmwareblob.so"