blob: e0973759fba935092eba60ee25faaacab7378575 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001require grub2.inc
2
Brad Bishop316dfdd2018-06-25 12:45:53 -04003RDEPENDS_${PN}-common += "${PN}-editenv"
4RDEPENDS_${PN} += "diffutils freetype ${PN}-common"
5
6RPROVIDES_${PN}-editenv += "${PN}-efi-editenv"
7
8PACKAGES =+ "${PN}-editenv ${PN}-common"
9FILES_${PN}-editenv = "${bindir}/grub-editenv"
10FILES_${PN}-common = " \
11 ${bindir} \
12 ${sysconfdir} \
13 ${sbindir} \
14 ${datadir}/grub \
15"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016
17do_install_append () {
18 install -d ${D}${sysconfdir}/grub.d
19 # Remove build host references...
20 find "${D}" -name modinfo.sh -type f -exec \
21 sed -i \
22 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
23 -e 's|${DEBUG_PREFIX_MAP}||g' \
24 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
25 {} +
26}
27
28INSANE_SKIP_${PN} = "arch"
29INSANE_SKIP_${PN}-dbg = "arch"