blob: 8b71c2bd6c0f8cccc8be107b32fd9ab99436445f [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Plymouth is a project from Fedora providing a flicker-free graphical boot process."
2
3DESCRIPTION = "Plymouth is an application that runs very early in the boot process \
4 (even before the root filesystem is mounted!) that provides a \
5 graphical boot animation while the boot process happens in the background. \
6"
7
8HOMEPAGE = "http://www.freedesktop.org/wiki/Software/Plymouth"
9SECTION = "base"
10
11LICENSE = "GPLv2+"
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
14
15DEPENDS = "libcap libpng cairo dbus udev"
16PROVIDES = "virtual/psplash"
17RPROVIDES_${PN} = "virtual-psplash virtual-psplash-support"
18
19SRC_URI = " \
20 http://www.freedesktop.org/software/plymouth/releases/${BPN}-${PV}.tar.xz \
21 file://0001-Make-full-path-to-systemd-tty-ask-password-agent-con.patch \
22 "
23
24SRC_URI[md5sum] = "4efa5551d230165981b105e7c6a50aa7"
25SRC_URI[sha256sum] = "4a197a4f1a05785d7453dd829b231352fb2d09171bd86c5ffaafbb2dd6791351"
26
27EXTRA_OECONF += " --enable-shared --disable-static --disable-gtk --disable-documentation \
28 --with-logo=${LOGO} \
Andrew Geissler82c905d2020-04-13 13:39:40 -050029 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--enable-systemd-integration --with-systemd-tty-ask-password-agent=${base_bindir}/systemd-tty-ask-password-agent', '', d)} \
30 ${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge','--without-system-root-install','--with-system-root-install',d)} \
Brad Bishop19323692019-04-05 15:28:33 -040031"
32
33PACKAGECONFIG ??= "pango initrd"
34PACKAGECONFIG_append_x86 = " drm"
35PACKAGECONFIG_append_x86-64 = " drm"
36
37PACKAGECONFIG[drm] = "--enable-drm,--disable-drm,libdrm"
38PACKAGECONFIG[pango] = "--enable-pango,--disable-pango,pango"
39PACKAGECONFIG[gtk] = "--enable-gtk,--disable-gtk,gtk+3"
40PACKAGECONFIG[initrd] = ",,,"
41
42LOGO ??= "${datadir}/plymouth/bizcom.png"
43
44inherit autotools pkgconfig systemd
45
46do_install_append() {
47 # Remove /var/run from package as plymouth will populate it on startup
48 rm -fr "${D}${localstatedir}/run"
49
50 if ! ${@bb.utils.contains('PACKAGECONFIG', 'initrd', 'true', 'false', d)}; then
51 rm -rf "${D}${libexecdir}"
52 fi
53}
54
55PACKAGES =. "${@bb.utils.contains('PACKAGECONFIG', 'initrd', '${PN}-initrd ', '', d)}"
56PACKAGES =+ "${PN}-set-default-theme"
57
58FILES_${PN}-initrd = "${libexecdir}/plymouth/*"
59FILES_${PN}-set-default-theme = "${sbindir}/plymouth-set-default-theme"
60
61FILES_${PN} += "${systemd_unitdir}/system/*"
62FILES_${PN}-dbg += "${libdir}/plymouth/renderers/.debug"
63
64
65RDEPENDS_${PN}-initrd = "bash dracut"
66RDEPENDS_${PN}-set-default-theme = "bash"
67
68SYSTEMD_SERVICE_${PN} = "plymouth-start.service"