blob: 04f82d2bcd42eda3ecf685e75f46f7fc6b590a68 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Set of CLI tools for Openlmi providers"
2DESCRIPTION = "openlmi-tools is a set of command line tools for Openlmi providers."
3HOMEPAGE = "http://www.openlmi.org/"
4LICENSE = "GPLv2+"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08005LIC_FILES_CHKSUM = "file://../COPYING;md5=75859989545e37968a99b631ef42722e"
Patrick Williamsb48b7b42016-08-17 15:04:38 -05006SECTION = "System/Management"
7
Andrew Geissler82c905d2020-04-13 13:39:40 -05008inherit ${@bb.utils.contains("BBFILE_COLLECTIONS", "meta-python2", "setuptools", "", d)}
Patrick Williamsb48b7b42016-08-17 15:04:38 -05009
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080010DEPENDS = "python-native python-pywbem-native python-m2crypto python-pywbem"
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011
12SRC_URI = "http://fedorahosted.org/released/${BPN}/${BP}.tar.gz \
13 "
14SRC_URI[md5sum] = "e156246cb7b49753db82f4ddf7f03e50"
15SRC_URI[sha256sum] = "292b8f5f2250655a4add8183c529b73358bc980bd4f23cfa484a940953fce9e4"
16
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080017S = "${WORKDIR}/${BP}/cli"
18
19do_configure_prepend() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050020 sed 's/@@VERSION@@/$(VERSION)/g' ${S}/setup.py.skel > ${S}/setup.py
Patrick Williamsb48b7b42016-08-17 15:04:38 -050021}
Brad Bishopd7bf8c12018-02-25 22:55:05 -050022
23python() {
Andrew Geissler82c905d2020-04-13 13:39:40 -050024 if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
25 raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
Brad Bishopd7bf8c12018-02-25 22:55:05 -050026}