blob: 60040a47afc741b7f3fd228215ba709a3b96a44b [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001#
2# Copyright (C) 2013 Wind River Systems, Inc.
3#
4# This program is free software; you can redistribute it and/or modify
5# it under the terms of the GNU General Public License version 2 as
6# published by the Free Software Foundation.
7#
8SUMMARY = "Frequency and Idle power monitoring tools for Linux"
9
10DESCRIPTION = "The turbostat tool allows you to determine the actual \
11processor frequency and idle power saving state residency on supported \
12processors."
13
14LICENSE = "GPLv2"
15LIC_FILES_CHKSUM = "file://../COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
16COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
17COMPATIBLE_HOST_libc-musl = "null"
18
19SRC_URI += "\
20 file://COPYING \
21 "
22
Brad Bishop26bdd442019-08-16 17:08:17 -040023PACKAGE_ARCH = "${MACHINE_ARCH}"
Andrew Geissler82c905d2020-04-13 13:39:40 -050024DEPENDS = "libcap"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080025
26# This looks in S, so we better make sure there's
27# something in the directory.
28#
29do_populate_lic[depends] = "${PN}:do_configure"
30
31
32EXTRA_OEMAKE = '\
Andrew Geissler82c905d2020-04-13 13:39:40 -050033 CC="${CC}" 'CFLAGS=-Wall ${LDFLAGS}' \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080034 '
35
36# If we build under STAGING_KERNEL_DIR, source will not be put
37# into the dbg rpm. STAGING_KERNEL_DIR will exist by the time
38# do_configure() is invoked so we can safely copy from it.
39#
Andrew Geissler82c905d2020-04-13 13:39:40 -050040do_configure[depends] += "virtual/kernel:do_shared_workdir"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080041do_configure_prepend() {
42 mkdir -p ${S}
43 cp -r ${STAGING_KERNEL_DIR}/arch/x86/include/asm/msr-index.h ${S}
44 cp -r ${STAGING_KERNEL_DIR}/arch/x86/include/asm/intel-family.h ${S}
Brad Bishop15ae2502019-06-18 21:44:24 -040045 cp -r ${STAGING_KERNEL_DIR}/include/linux/bits.h ${S}
Andrew Geissler82c905d2020-04-13 13:39:40 -050046 cp -r ${STAGING_KERNEL_DIR}/include/linux/const.h ${S}
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080047 cp -r ${STAGING_KERNEL_DIR}/tools/power/x86/turbostat/* ${S}
48 cp -r ${WORKDIR}/COPYING ${S}
49}
50
51do_compile() {
Brad Bishop15ae2502019-06-18 21:44:24 -040052 sed -i 's#<linux/bits.h>#"bits.h"#' msr-index.h
Andrew Geissler82c905d2020-04-13 13:39:40 -050053 sed -i 's#<linux/const.h>#"const.h"#' bits.h
54 sed -i -e 's#<uapi/linux/const.h>#<linux/const.h>#' -e 's#_LINUX_CONST_H#_LINUX_CONST_H_KERNEL#' const.h
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080055 sed -i 's#MSRHEADER#"msr-index.h"#' turbostat.c
56 sed -i 's#INTEL_FAMILY_HEADER#"intel-family.h"#' turbostat.c
57 sed -i 's#\$(CC) \$(CFLAGS) \$< -o \$(BUILD_OUTPUT)/\$@#\$(CC) \$(CFLAGS) \$(LDFLAGS) \$< -o \$(BUILD_OUTPUT)/\$@#' Makefile
58 oe_runmake STAGING_KERNEL_DIR=${STAGING_KERNEL_DIR}
59}
60
61do_install() {
62 oe_runmake DESTDIR="${D}" install
63}