blob: 3800d147f95f012bf8c1aeeddf6bd267ce638787 [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Console mouse driver"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05002DESCRIPTION = "GPM (General Purpose Mouse) is a mouse server \
3for the console and xterm, with sample clients included \
4(emacs, etc)."
Brad Bishopc342db32019-05-15 21:57:59 -04005HOMEPAGE = "https://www.nico.schottelius.org/software/gpm"
Brad Bishop6e60e8b2018-02-01 10:27:11 -05006SECTION = "console/utils"
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
9
10PV = "1.99.7+git${SRCREV}"
11PR = "r2"
12SRCREV = "1fd19417b8a4dd9945347e98dfa97e4cfd798d77"
13
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080014DEPENDS = "ncurses bison-native"
Brad Bishop6e60e8b2018-02-01 10:27:11 -050015
16SRC_URI = "git://github.com/telmich/gpm;protocol=git \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050017 file://init \
Brad Bishop6e60e8b2018-02-01 10:27:11 -050018 file://gpm.service.in \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050019 file://0001-Use-sigemptyset-API-instead-of-__sigemptyset.patch \
20 "
Brad Bishop6e60e8b2018-02-01 10:27:11 -050021
22S = "${WORKDIR}/git"
23
Andrew Geissler82c905d2020-04-13 13:39:40 -050024inherit autotools-brokensep update-rc.d systemd texinfo
Brad Bishop6e60e8b2018-02-01 10:27:11 -050025
26INITSCRIPT_NAME = "gpm"
27INITSCRIPT_PARAMS = "defaults"
28
29do_configure_prepend() {
30 (cd ${S};./autogen.sh;cd -)
31}
32
33do_install_append () {
Brad Bishopc342db32019-05-15 21:57:59 -040034 install -d ${D}${systemd_system_unitdir}
35 sed 's:@bindir@:${sbindir}:' < ${WORKDIR}/gpm.service.in >${D}${systemd_system_unitdir}/gpm.service
36 install -D -m 0755 ${WORKDIR}/init ${D}${INIT_D_DIR}/gpm
Brad Bishop6e60e8b2018-02-01 10:27:11 -050037 ln -s libgpm.so.2 ${D}${libdir}/libgpm.so
38}
39
40SYSTEMD_SERVICE_${PN} = "gpm.service"