blob: 081d740424049a6613dd3526379af9990dd5e050 [file] [log] [blame]
Potin Laie096c412022-09-01 14:12:25 +08001LICENSE = "Apache-2.0"
2LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
3
4inherit obmc-phosphor-systemd
5
6RDEPENDS:${PN} += " bash motor-ctrl"
Potin Lai83c294d2022-10-17 16:24:32 +08007RDEPENDS:${PN} += " mdio-tools"
Potin Laie096c412022-09-01 14:12:25 +08008
9SRC_URI += " \
10 file://bletchley-system-state-init \
11 file://bletchley-system-state-init@.service \
Potin Lai83c294d2022-10-17 16:24:32 +080012 file://bletchley-switch-diag \
Potin Laie096c412022-09-01 14:12:25 +080013 "
14
15do_install() {
16 install -d ${D}${libexecdir}
17 install -m 0755 ${WORKDIR}/bletchley-system-state-init ${D}${libexecdir}
Potin Lai83c294d2022-10-17 16:24:32 +080018 install -m 0755 ${WORKDIR}/bletchley-switch-diag ${D}${libexecdir}
Potin Laie096c412022-09-01 14:12:25 +080019}
20
21
22TGT = "${SYSTEMD_DEFAULT_TARGET}"
23BLETCHLEY_SYS_ST_INIT_INSTFMT="../bletchley-system-state-init@.service:${TGT}.wants/bletchley-system-state-init@{0}.service"
24
25SYSTEMD_SERVICE:${PN} += "bletchley-system-state-init@.service"
26SYSTEMD_LINK:${PN} += "${@compose_list(d, 'BLETCHLEY_SYS_ST_INIT_INSTFMT', 'OBMC_HOST_INSTANCES')}"