blob: 0ab2be9db1f76f2f5faa537f60b15a3707ba1bdd [file] [log] [blame]
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +05301SUMMARY = "Phosphor Watchdog application"
2DESCRIPTION = "Application that implements software watchdog"
3HOMEPAGE = "http://github.com/openbmc/phosphor-watchdog"
4PR = "r1"
5
6LICENSE = "Apache-2.0"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
8inherit autotools pkgconfig
9inherit obmc-phosphor-dbus-service
10
11RPROVIDES_${PN} += "virtual/obmc-watchdog"
12PROVIDES += "virtual/obmc-watchdog"
13
14DEPENDS += "autoconf-archive-native"
15DEPENDS += "sdbusplus sdbusplus-native"
William A. Kennington III83d610a2018-09-13 23:32:19 -070016DEPENDS += "sdeventplus"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053017DEPENDS += "phosphor-dbus-interfaces"
18DEPENDS += "phosphor-logging"
19RDEPENDS_${PN} += "libsystemd"
20RDEPENDS_${PN} += "phosphor-logging"
21
22SRC_URI += "git://github.com/openbmc/phosphor-watchdog"
Andrew Geissler9e5e2b02018-09-13 16:00:28 +000023SRCREV = "8f6c51564d634eb26f1ca8aa599fbbda19e06dec"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053024S = "${WORKDIR}/git"
25
26# Copies config file having arguments for host watchdog
27SYSTEMD_ENVIRONMENT_FILE_${PN} +="obmc/watchdog/poweron"
28
29# Install the override to set up a Conflicts relation
30SYSTEMD_OVERRIDE_${PN} += "poweron.conf:phosphor-watchdog@poweron.service.d/poweron.conf"
31
32# For now, watching PowerOn is the only usecase
33OBMC_HOST_WATCHDOG_INSTANCES = "poweron"
34
35# This is really a DBUS service but the service name is
36# an argument, so making it this way.
37WATCHDOG_TMPL = "phosphor-watchdog@.service"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053038ENABLE_WATCHDOG_TMPL = "obmc-enable-host-watchdog@.service"
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053039SYSTEMD_SERVICE_${PN} += "${WATCHDOG_TMPL}"
40
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053041# To Enable Host Watchdog early during poweron
42SYSTEMD_SERVICE_${PN} += "${ENABLE_WATCHDOG_TMPL}"
43
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053044WATCHDOG_TGTFMT = "phosphor-watchdog@{0}.service"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053045ENABLE_WATCHDOG_TGTFMT = "obmc-enable-host-watchdog@{0}.service"
46
Andrew Geissler5c76e0c2018-03-27 13:56:26 -070047WATCHDOG_FMT = "../${WATCHDOG_TMPL}:obmc-host-startmin@{1}.target.wants/${WATCHDOG_TGTFMT}"
48ENABLE_WATCHDOG_FMT = "../${ENABLE_WATCHDOG_TMPL}:obmc-host-startmin@{0}.target.wants/${ENABLE_WATCHDOG_TGTFMT}"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053049
Vishwanatha Subbanna2d78dd02017-06-12 13:09:10 +053050SYSTEMD_LINK_${PN} += "${@compose_list(d, 'WATCHDOG_FMT', 'OBMC_HOST_WATCHDOG_INSTANCES', 'OBMC_HOST_INSTANCES')}"
Vishwanatha Subbannab5e56442017-07-03 19:21:18 +053051SYSTEMD_LINK_${PN} += "${@compose_list(d, 'ENABLE_WATCHDOG_FMT', 'OBMC_HOST_INSTANCES')}"