blob: b92f82dec2a47e673173ab63b9fe5861dd370357 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Protocol Buffers - structured data serialisation mechanism"
2DESCRIPTION = "This is protobuf-c, a C implementation of the Google Protocol Buffers data \
3serialization format. It includes libprotobuf-c, a pure C library that \
4implements protobuf encoding and decoding, and protoc-c, a code generator that \
5converts Protocol Buffer .proto files to C descriptor code, based on the \
6original protoc. protobuf-c formerly included an RPC implementation; that code \
7has been split out into the protobuf-c-rpc project."
8HOMEPAGE = "https://github.com/protobuf-c/protobuf-c"
9SECTION = "console/tools"
10LICENSE = "BSD-2-Clause"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=cb901168715f4782a2b06c3ddaefa558"
12
13DEPENDS = "protobuf-native protobuf"
14
Brad Bishop26bdd442019-08-16 17:08:17 -040015SRCREV = "1390409f4ee4e26d0635310995b516eb702c3f9e"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080016
Brad Bishopc8f47122019-06-24 09:36:18 -040017SRC_URI = "git://github.com/protobuf-c/protobuf-c.git \
Brad Bishop36a3e3e2019-10-02 13:29:27 -040018 file://0001-avoid-race-condition.patch \
Brad Bishopc8f47122019-06-24 09:36:18 -040019 "
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080020
21S = "${WORKDIR}/git"
22
23#make sure c++11 is used
24CXXFLAGS += "-std=c++11"
25BUILD_CXXFLAGS += "-std=c++11"
26
27inherit autotools pkgconfig
28
29PACKAGE_BEFORE_PN = "${PN}-compiler"
30
31FILES_${PN}-compiler = "${bindir}"
32
33RDEPENDS_${PN}-compiler = "protobuf-compiler"
34RDEPENDS_${PN}-dev += "${PN}-compiler"
35
36BBCLASSEXTEND = "native nativesdk"