blob: 2094ebe3e7f4c9569ddfc9315710eaff3d92de8d [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "JSON-GLib implements a full JSON parser using GLib and GObject"
2DESCRIPTION = "Use JSON-GLib it is possible to parse and generate valid JSON\
3 data structures, using a DOM-like API. JSON-GLib also offers GObject \
4integration, providing the ability to serialize and deserialize GObject \
5instances to and from JSON data types."
6HOMEPAGE = "https://wiki.gnome.org/Projects/JsonGlib"
7BUGTRACKER = "https://gitlab.gnome.org/GNOME/json-glib/issues"
8
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00009LICENSE = "LGPL-2.1-only"
Andrew Geisslereff27472021-10-29 15:35:00 -050010LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
11
Patrick Williams8e7b46e2023-05-01 14:19:06 -050012DEPENDS = "glib-2.0 glib-2.0-native"
Andrew Geisslereff27472021-10-29 15:35:00 -050013
Andrew Geisslereff27472021-10-29 15:35:00 -050014inherit gnomebase lib_package gobject-introspection gi-docgen gettext ptest-gnome manpages upstream-version-is-even
15GIR_MESON_ENABLE_FLAG = 'enabled'
16GIR_MESON_DISABLE_FLAG = 'disabled'
17GIDOCGEN_MESON_ENABLE_FLAG = 'enabled'
18GIDOCGEN_MESON_DISABLE_FLAG = 'disabled'
19
20SRC_URI += " file://run-ptest"
Patrick Williams169d7bc2024-01-05 11:33:25 -060021SRC_URI[archive.sha256sum] = "97ef5eb92ca811039ad50a65f06633f1aae64792789307be7170795d8b319454"
Andrew Geisslereff27472021-10-29 15:35:00 -050022
23PACKAGECONFIG ??= "${@bb.utils.contains('PTEST_ENABLED', '1', 'tests', '', d)}"
24PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false,libxslt-native xmlto-native"
25PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false"
26
27BBCLASSEXTEND = "native nativesdk"
28
29# Currently it's not possible to disable gettext in Meson, so we need to force
30# this back on.
31USE_NLS:class-native = "yes"