Patrick Williams | 92b42cb | 2022-09-03 06:53:57 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Very fast, header only, C++ logging library." |
| 2 | HOMEPAGE = "https://github.com/gabime/spdlog/wiki" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" |
| 5 | |
| 6 | SRCREV = "76fb40d95455f249bd70824ecfcae7a8f0930fa3" |
| 7 | SRC_URI = "git://github.com/gabime/spdlog.git;protocol=https;branch=v1.x" |
| 8 | |
| 9 | DEPENDS += "fmt" |
| 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
| 13 | BBCLASSEXTEND = "native" |
| 14 | # no need to build example & tests & benchmarks on pure yocto |
| 15 | EXTRA_OECMAKE += "-DSPDLOG_INSTALL=on -DSPDLOG_BUILD_SHARED=on -DSPDLOG_BUILD_EXAMPLE=off -DSPDLOG_BUILD_TESTS=off -DSPDLOG_BUILD_BENCH=off -DSPDLOG_FMT_EXTERNAL=on" |
| 16 | |
| 17 | inherit cmake |