Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Library to handle input devices in Wayland compositors" |
| 2 | DESCRIPTION = "libinput is a library to handle input devices in Wayland \ |
| 3 | compositors and to provide a generic X.Org input driver. It provides \ |
| 4 | device detection, device handling, input device event processing and \ |
| 5 | abstraction so minimize the amount of custom input code compositors need to \ |
| 6 | provide the common set of functionality that users expect." |
| 7 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/" |
| 8 | SECTION = "libs" |
| 9 | |
| 10 | LICENSE = "MIT" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=bab4ac7dc1c10bc0fb037dc76c46ef8a" |
| 12 | |
| 13 | DEPENDS = "libevdev udev mtdev libcheck" |
| 14 | |
| 15 | SRC_URI = "http://www.freedesktop.org/software/${BPN}/${BP}.tar.xz \ |
| 16 | file://run-ptest \ |
| 17 | file://determinism.patch \ |
| 18 | " |
Andrew Geissler | d583833 | 2022-05-27 11:33:10 -0500 | [diff] [blame] | 19 | SRC_URI[sha256sum] = "ff33a570b5a936c81e6c08389a8581c2665311d026ce3d225c88d09c49f9b440" |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 20 | |
| 21 | UPSTREAM_CHECK_REGEX = "libinput-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)" |
| 22 | |
| 23 | inherit meson pkgconfig lib_package ptest |
| 24 | |
| 25 | # Patch out build directory, otherwise it leaks into ptest binary |
| 26 | do_configure:append() { |
| 27 | sed -i -e "s,${WORKDIR},,g" config.h |
| 28 | if [ -e "litest-config.h" ]; then |
| 29 | sed -i -e "s,${WORKDIR},,g" litest-config.h |
| 30 | fi |
| 31 | } |
| 32 | |
| 33 | PACKAGECONFIG ??= "" |
| 34 | PACKAGECONFIG[libwacom] = "-Dlibwacom=true,-Dlibwacom=false,libwacom" |
| 35 | PACKAGECONFIG[gui] = "-Ddebug-gui=true,-Ddebug-gui=false,cairo gtk+3" |
| 36 | |
| 37 | UDEVDIR = "`pkg-config --variable=udevdir udev`" |
| 38 | |
| 39 | EXTRA_OEMESON += "-Dudev-dir=${UDEVDIR} \ |
| 40 | -Ddocumentation=false \ |
| 41 | ${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true -Dinstall-tests=true', '-Dtests=false -Dinstall-tests=false', d)} \ |
| 42 | -Dzshcompletiondir=no" |
| 43 | |
| 44 | # package name changed in 1.8.1 upgrade: make sure package upgrades work |
| 45 | RPROVIDES:${PN} = "libinput" |
| 46 | RREPLACES:${PN} = "libinput" |
| 47 | RCONFLICTS:${PN} = "libinput" |
| 48 | |
| 49 | FILES:${PN}-ptest += "${libexecdir}/libinput/libinput-test-suite" |