blob: 8ccdc27a8effd1c814489753e68d14f16f7cdeac [file] [log] [blame]
Brad Bishop36a3e3e2019-10-02 13:29:27 -04001SUMMARY = "A small tool to read/write memory"
Brad Bishop00ab2372019-10-14 11:06:18 -04002DESCRIPTION = "rwmem is a small tool for reading and writing device registers. \
3rwmem supports two modes: mmap mode and i2c mode. \
4\
5In mmap mode rwmem accesses a file by memory mapping it. \
6Using /dev/mem as the memory mapped file makes rwmem access memory and \
7can thus be used to access devices which have memory mapped registers. \
8\
9In i2c mode rwmem accesses an i2c peripheral by sending i2c messages to it."
10
Andrew Geissler9aee5002022-03-30 16:27:02 +000011LICENSE = "GPL-2.0-or-later"
Brad Bishop36a3e3e2019-10-02 13:29:27 -040012LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
13
Patrick Williams864cc432023-02-09 14:54:44 -060014DEPENDS += "fmt libinih"
Brad Bishop36a3e3e2019-10-02 13:29:27 -040015
16PV .= "+git${SRCPV}"
17
Patrick Williams864cc432023-02-09 14:54:44 -060018SRCREV = "8416326777b2aada0706539b8f9f6acefa476b16"
Brad Bishop36a3e3e2019-10-02 13:29:27 -040019
Patrick Williams864cc432023-02-09 14:54:44 -060020SRC_URI = "git://github.com/tomba/rwmem.git;protocol=https;name=rwmem;branch=master \
21 file://0001-include-missing-cstdint.patch"
Brad Bishop36a3e3e2019-10-02 13:29:27 -040022
23S = "${WORKDIR}/git"
24
Patrick Williams864cc432023-02-09 14:54:44 -060025inherit meson pkgconfig python3native
Brad Bishop36a3e3e2019-10-02 13:29:27 -040026
Patrick Williams864cc432023-02-09 14:54:44 -060027PACKAGECONFIG ?= "python static"
28PACKAGECONFIG[python] = "-Dpyrwmem=enabled,-Dpyrwmem=disabled,cmake-native python3 python3-pybind11"
29PACKAGECONFIG[static] = "-Dstatic-libc=true,-Dstatic-libc=false,"
30
31do_install:append() {
32 install -D -m 0644 ${B}/librwmem/librwmem.a ${D}${libdir}/librwmem.a
Brad Bishop36a3e3e2019-10-02 13:29:27 -040033}
Patrick Williams864cc432023-02-09 14:54:44 -060034
35FILES:${PN} += "${libdir}/python3.11/site-packages/pyrwmem"