blob: 92897cd3fc7ed9a6d620fc3a62240daab44dab95 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "A New System Troubleshooting Tool Built for the Way You Work"
2DESCRIPTION = "Sysdig is open source, system-level exploration: capture \
3system state and activity from a running Linux instance, then save, \
4filter and analyze."
5HOMEPAGE = "http://www.sysdig.org/"
6LICENSE = "Apache-2.0 & (MIT | GPL-2.0-only)"
7LIC_FILES_CHKSUM = "file://COPYING;md5=f8fee3d59797546cffab04f3b88b2d44"
8
9inherit cmake pkgconfig
10
11#OECMAKE_GENERATOR = "Unix Makefiles"
12JIT ?= "jit"
13JIT:mipsarchn32 = ""
14JIT:mipsarchn64 = ""
15JIT:riscv64 = ""
16JIT:riscv32 = ""
17JIT:powerpc = ""
18JIT:powerpc64le = ""
19JIT:powerpc64 = ""
20
21DEPENDS += "libb64 lua${JIT} zlib c-ares grpc-native grpc curl ncurses jsoncpp \
22 tbb jq openssl elfutils protobuf protobuf-native jq-native valijson"
23RDEPENDS:${PN} = "bash"
24
25SRC_URI = "git://github.com/draios/sysdig.git;branch=dev;protocol=https;name=sysdig \
26 git://github.com/falcosecurity/libs;protocol=https;branch=master;name=falco;subdir=git/falcosecurity-libs \
Patrick Williams864cc432023-02-09 14:54:44 -060027 file://0001-Add-cstdint-for-uintXX_t-types.patch;patchdir=./falcosecurity-libs \
Andrew Geissler9aee5002022-03-30 16:27:02 +000028 file://0001-cmake-Pass-PROBE_NAME-via-CFLAGS.patch \
29 "
30SRCREV_sysdig = "4fb6288275f567f63515df0ff0a6518043ecfa9b"
31SRCREV_falco= "caa0e4d0044fdaaebab086592a97f0c7f32aeaa9"
32
33S = "${WORKDIR}/git"
34
35EXTRA_OECMAKE = "\
36 -DBUILD_DRIVER=OFF \
37 -DMINIMAL_BUILD=ON \
38 -DUSE_BUNDLED_DEPS=OFF \
39 -DCREATE_TEST_TARGETS=OFF \
40 -DDIR_ETC=${sysconfdir} \
41 -DLUA_INCLUDE_DIR=${STAGING_INCDIR}/luajit-2.1 \
42 -DFALCOSECURITY_LIBS_SOURCE_DIR=${S}/falcosecurity-libs \
43 -DVALIJSON_INCLUDE=${STAGING_INCDIR}/valijson \
44"
45
46#CMAKE_VERBOSE = "VERBOSE=1"
47
48FILES:${PN} += " \
49 ${DIR_ETC}/* \
50 ${datadir}/zsh/* \
51 ${prefix}/src/* \
52"
53# Use getaddrinfo_a is a GNU extension in libsinsp
54# It should be fixed in sysdig, until then disable
55# on musl
56# Something like this https://code.videolan.org/ePirat/vlc/-/commit/01fd9fe4c7f6c5558f7345f38abf0152e17853ab is needed to fix it
57COMPATIBLE_HOST:libc-musl = "null"
58COMPATIBLE_HOST:mips = "null"
59COMPATIBLE_HOST:riscv64 = "null"
60COMPATIBLE_HOST:riscv32 = "null"
61COMPATIBLE_HOST:powerpc = "null"
62COMPATIBLE_HOST:powerpc64le = "null"