blob: f68107df87ab6342426f3d281d35624d5646769e [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Smart card library and applications"
2DESCRIPTION = "OpenSC is a tool for accessing smart card devices. Basic\
3functionality (e.g. SELECT FILE, READ BINARY) should work on any ISO\
47816-4 compatible smart card. Encryption and decryption using private\
5keys on the smart card is possible with PKCS\
6such as the FINEID (Finnish Electronic IDentity) card. Swedish Posten\
7eID cards have also been confirmed to work."
8
Andrew Geisslerc5535c92023-01-27 16:10:19 -06009HOMEPAGE = "https://github.com/OpenSC/OpenSC/wiki"
Andrew Geissler517393d2023-01-13 08:55:19 -060010SECTION = "System Environment/Libraries"
11LICENSE = "LGPL-2.0-or-later"
12LIC_FILES_CHKSUM = "file://COPYING;md5=cb8aedd3bced19bd8026d96a8b6876d7"
13
14#v0.21.0
15SRCREV = "5497519ea6b4af596628f8f8f2f904bacaa3148f"
16SRC_URI = "git://github.com/OpenSC/OpenSC;branch=master;protocol=https \
Patrick Williams864cc432023-02-09 14:54:44 -060017 file://0001-pkcs11-tool-Fix-private-key-import.patch \
18 file://0002-pkcs11-tool-Log-more-information-on-OpenSSL-errors.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060019 "
20DEPENDS = "virtual/libiconv openssl"
21
22S = "${WORKDIR}/git"
23inherit autotools pkgconfig bash-completion
24
25EXTRA_OECONF = " \
26 --disable-static \
27 --disable-ctapi \
28 --disable-doc \
29 --disable-strict \
30"
31EXTRA_OEMAKE = "DESTDIR=${D}"
32
33PACKAGECONFIG ??= "pcsc"
34
35PACKAGECONFIG[openct] = "--enable-openct,--disable-openct,openct"
36PACKAGECONFIG[pcsc] = "--enable-pcsc,--disable-pcsc,pcsc-lite,pcsc-lite pcsc-lite-lib"
37
38RDEPENDS:${PN} = "readline"
39
40FILES:${PN} += "\
41 ${libdir}/opensc-pkcs11.so \
42 ${libdir}/onepin-opensc-pkcs11.so \
43 ${libdir}/pkcs11-spy.so \
44"
45FILES:${PN}-dev += "\
46 ${libdir}/pkcs11/opensc-pkcs11.so \
47 ${libdir}/pkcs11/onepin-opensc-pkcs11.so \
48 ${libdir}/pkcs11/pkcs11-spy.so \
49"
50
51BBCLASSEXTEND = "native"