blob: 9f1cc9eac585191e66b6433f9e3697896fd6bc9b [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \
2Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \
3Contributors."
4HOMEPAGE = "https://pillow.readthedocs.io"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=bc416d18f294943285560364be7cbec1"
7
8SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=main;protocol=https \
9 file://0001-support-cross-compiling.patch \
10 file://0001-explicitly-set-compile-options.patch \
Patrick Williams864cc432023-02-09 14:54:44 -060011 file://run-ptest \
Andrew Geissler517393d2023-01-13 08:55:19 -060012 "
13SRCREV ?= "82541b6dec8452cb612067fcebba1c5a1a2bfdc8"
14
Patrick Williams864cc432023-02-09 14:54:44 -060015inherit setuptools3 ptest
Andrew Geissler517393d2023-01-13 08:55:19 -060016
17PIP_INSTALL_PACKAGE = "Pillow"
18PIP_INSTALL_DIST_PATH = "${S}/dist"
19
20DEPENDS += " \
21 zlib \
22 jpeg \
23 tiff \
24 freetype \
25 lcms \
26 openjpeg \
27"
28
29RDEPENDS:${PN} += " \
30 ${PYTHON_PN}-misc \
31 ${PYTHON_PN}-logging \
32 ${PYTHON_PN}-numbers \
33"
34
Patrick Williams864cc432023-02-09 14:54:44 -060035RDEPENDS:${PN}-ptest += " \
36 bash \
37 ghostscript \
38 jpeg-tools \
39 libwebp \
40 ${PYTHON_PN}-core \
41 ${PYTHON_PN}-image \
42 ${PYTHON_PN}-mmap \
43 ${PYTHON_PN}-pytest \
44 ${PYTHON_PN}-pytest-timeout \
45 ${PYTHON_PN}-resource \
46 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'tk', '', d)} \
47"
48
Andrew Geissler517393d2023-01-13 08:55:19 -060049CVE_PRODUCT = "pillow"
50
51S = "${WORKDIR}/git"
52
53RPROVIDES:${PN} += "python3-imaging"
54
Patrick Williams864cc432023-02-09 14:54:44 -060055do_install_ptest() {
56 install -d ${D}${PTEST_PATH}/Tests
57 cp -rf ${S}/Tests ${D}${PTEST_PATH}/
58}
59
Andrew Geissler517393d2023-01-13 08:55:19 -060060BBCLASSEXTEND = "native"
61
62SRCREV = "a5bbab1c1e63b439de191ef2040173713b26d2da"