blob: 9767c95d30430b05f4fe9f1587c63fa9bb50a8e0 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Tooling for devicetree validation using YAML and jsonschema"
2HOMEPAGE = "https://github.com/devicetree-org/dt-schema"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=457495c8fa03540db4a576bf7869e811"
5
6inherit pypi setuptools3
7
8PYPI_PACKAGE = "dtschema"
9
Patrick Williams864cc432023-02-09 14:54:44 -060010SRC_URI[sha256sum] = "8fc8c269e4c57e9d008af7b32cd33b77afd4ea1ac9552bcfa96b41b9e0c52586"
Andrew Geissler517393d2023-01-13 08:55:19 -060011
12DEPENDS += "python3-setuptools-scm-native"
13RDEPENDS:${PN} += "python3-ruamel-yaml python3-jsonschema python3-rfc3987"
14
15BBCLASSEXTEND = "native nativesdk"