blob: f75988a6a0dd695d7675765c168da3f0694afffb [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Python documentation generator"
2HOMEPAGE = "http://sphinx-doc.org/"
3SECTION = "devel/python"
4LICENSE = "BSD-2-Clause & MIT & BSD-3-Clause"
Patrick Williams864cc432023-02-09 14:54:44 -06005LIC_FILES_CHKSUM = "file://LICENSE;md5=066da51ab732319a06beae4f10788577"
Andrew Geissler517393d2023-01-13 08:55:19 -06006
7PYPI_PACKAGE = "Sphinx"
8
Patrick Williams864cc432023-02-09 14:54:44 -06009SRC_URI[sha256sum] = "0dac3b698538ffef41716cf97ba26c1c7788dba73ce6f150c1ff5b4720786dd2"
Andrew Geissler517393d2023-01-13 08:55:19 -060010
11inherit python_flit_core pypi
12
13
14do_install:append () {
15 # The cache format of "{None, 'en', 'ja'}" doesn't seem to be consistent (dict ordering?)
16 rm ${D}${libdir}/${PYTHON_DIR}/site-packages/sphinx/writers/__pycache__/*latex*
17}
18
19RDEPENDS:${PN} = "\
20 python3-alabaster \
21 python3-babel \
22 python3-docutils \
23 python3-imagesize \
24 python3-jinja2 \
25 python3-packaging \
26 python3-pygments \
27 python3-requests \
28 python3-snowballstemmer \
29 python3-sphinxcontrib-applehelp \
30 python3-sphinxcontrib-devhelp \
31 python3-sphinxcontrib-htmlhelp \
32 python3-sphinxcontrib-jsmath \
33 python3-sphinxcontrib-qthelp \
34 python3-sphinxcontrib-serializinghtml \
35 "
36
37BBCLASSEXTEND = "native nativesdk"