blob: 1b36e4254365e4c910b5ea74b1d9a4e24957a6b2 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001DESCRIPTION = "Backport of pathlib-compatible object wrapper for zip files"
2HOMEPAGE = "https://github.com/jaraco/zipp"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
5
Patrick Williams864cc432023-02-09 14:54:44 -06006SRC_URI[sha256sum] = "73efd63936398aac78fd92b6f4865190119d6c91b531532e798977ea8dd402eb"
Andrew Geissler517393d2023-01-13 08:55:19 -06007
8DEPENDS += "${PYTHON_PN}-setuptools-scm-native"
9
10inherit pypi python_setuptools_build_meta
11
12DEPENDS += "${PYTHON_PN}-toml-native"
13
14RDEPENDS:${PN} += "${PYTHON_PN}-compression \
15 ${PYTHON_PN}-math \
16 ${PYTHON_PN}-more-itertools"
17
18BBCLASSEXTEND = "native nativesdk"