blob: 2bb9e6f32d88b8f3606019124d7e594d1faab365 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001LICENSE = "GPL-3.0-or-later"
Brad Bishop19323692019-04-05 15:28:33 -04002LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
3
4require diffutils.inc
5
6SRC_URI = "${GNU_MIRROR}/diffutils/diffutils-${PV}.tar.xz \
7 file://run-ptest \
Brad Bishop79641f22019-09-10 07:20:22 -04008 file://0001-Skip-strip-trailing-cr-test-case.patch \
Andrew Geisslerd159c7f2021-09-02 21:05:58 -05009 "
Brad Bishop19323692019-04-05 15:28:33 -040010
Patrick Williams864cc432023-02-09 14:54:44 -060011SRC_URI[sha256sum] = "d80d3be90a201868de83d78dad3413ad88160cc53bcc36eb9eaf7c20dbf023f1"
Brad Bishop19323692019-04-05 15:28:33 -040012
13EXTRA_OECONF += "ac_cv_path_PR_PROGRAM=${bindir}/pr --without-libsigsegv-prefix"
14
Andrew Geisslerd159c7f2021-09-02 21:05:58 -050015# latest gnulib is no longer able to handle this - I dare not try to fix that maze of abstractions and generators
16CFLAGS:mingw32 = " -DSA_RESTART=0"
17
Brad Bishop19323692019-04-05 15:28:33 -040018# Fix "Argument list too long" error when len(TMPDIR) = 410
19acpaths = "-I ./m4"
20
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000021EXTRA_OEMAKE:append:mingw32 = " LIBS='-lbcrypt'"
Brad Bishop19323692019-04-05 15:28:33 -040022inherit ptest
23
Patrick Williams213cb262021-08-07 19:21:33 -050024RDEPENDS:${PN}-ptest += "make perl"
Brad Bishop19323692019-04-05 15:28:33 -040025
26do_install_ptest() {
27 t=${D}${PTEST_PATH}
28 install -D ${S}/build-aux/test-driver $t/build-aux/test-driver
29 cp -r ${S}/tests $t/
30 install ${B}/tests/Makefile $t/tests/
31 sed -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
32 -e 's|${DEBUG_PREFIX_MAP}||g' \
33 -e 's:${HOSTTOOLS_DIR}/::g' \
34 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
35 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
36 -e 's|^Makefile:|_Makefile:|' \
37 -e 's|bash|sh|' \
38 -e 's|^top_srcdir = \(.*\)|top_srcdir = ..\/|' \
39 -e 's|^srcdir = \(.*\)|srcdir = .|' \
40 -e 's|"`$(built_programs)`"|diff|' \
41 -e 's|gawk|awk|g' \
42 -i $t/tests/Makefile
43}