blob: e2cb512892b68f351c7c06652787f9e0dd8ea554 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Provides support for the Tag Image File Format (TIFF)"
2DESCRIPTION = "Library provides support for the Tag Image File Format \
3(TIFF), a widely used format for storing image data. This library \
4provide means to easily access and create TIFF image files."
5HOMEPAGE = "http://www.libtiff.org/"
6LICENSE = "BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://LICENSE.md;md5=a3e32d664d6db1386b4689c8121531c3"
8
9CVE_PRODUCT = "libtiff"
10
11SRC_URI = "http://download.osgeo.org/libtiff/tiff-${PV}.tar.gz"
12
13SRC_URI[sha256sum] = "c7a1d9296649233979fa3eacffef3fa024d73d05d589cb622727b5b08c423464"
14
15# exclude betas
16UPSTREAM_CHECK_REGEX = "tiff-(?P<pver>\d+(\.\d+)+).tar"
17
18# Tested with check from https://security-tracker.debian.org/tracker/CVE-2015-7313
19# and 4.3.0 doesn't have the issue
20CVE_CHECK_IGNORE += "CVE-2015-7313"
21# These issues only affect libtiff post-4.3.0 but before 4.4.0,
22# caused by 3079627e and fixed by b4e79bfa.
23CVE_CHECK_IGNORE += "CVE-2022-1622 CVE-2022-1623"
24# Issue is in jbig which we don't enable
25CVE_CHECK_IGNORE += "CVE-2022-1210"
26
27inherit autotools multilib_header
28
29CACHED_CONFIGUREVARS = "ax_cv_check_gl_libgl=no"
30
31PACKAGECONFIG ?= "cxx jpeg zlib lzma \
32 strip-chopping extrasample-as-alpha check-ycbcr-subsampling"
33
34PACKAGECONFIG[cxx] = "--enable-cxx,--disable-cxx,,"
35PACKAGECONFIG[jbig] = "--enable-jbig,--disable-jbig,jbig,"
36PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg,"
37PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib,"
38PACKAGECONFIG[lzma] = "--enable-lzma,--disable-lzma,xz,"
39PACKAGECONFIG[webp] = "--enable-webp,--disable-webp,libwebp,"
Patrick Williams864cc432023-02-09 14:54:44 -060040PACKAGECONFIG[zstd] = "--enable-zstd,--disable-zstd,zstd,"
41PACKAGECONFIG[libdeflate] = "--enable-libdeflate,--disable-libdeflate,libdeflate,"
Andrew Geissler517393d2023-01-13 08:55:19 -060042
43# Convert single-strip uncompressed images to multiple strips of specified
44# size (default: 8192) to reduce memory usage
45PACKAGECONFIG[strip-chopping] = "--enable-strip-chopping,--disable-strip-chopping,,"
46
47# Treat a fourth sample with no EXTRASAMPLE_ value as being ASSOCALPHA
48PACKAGECONFIG[extrasample-as-alpha] = "--enable-extrasample-as-alpha,--disable-extrasample-as-alpha,,"
49
50# Control picking up YCbCr subsample info. Disable to support files lacking
51# the tag
52PACKAGECONFIG[check-ycbcr-subsampling] = "--enable-check-ycbcr-subsampling,--disable-check-ycbcr-subsampling,,"
53
54# Support a mechanism allowing reading large strips (usually one strip files)
55# in chunks when using TIFFReadScanline. Experimental 4.0+ feature
56PACKAGECONFIG[chunky-strip-read] = "--enable-chunky-strip-read,--disable-chunky-strip-read,,"
57
58PACKAGES =+ "tiffxx tiff-utils"
59FILES:tiffxx = "${libdir}/libtiffxx.so.*"
60FILES:tiff-utils = "${bindir}/*"
61
62do_install:append() {
63 oe_multilib_header tiffconf.h
64}
65
66BBCLASSEXTEND = "native nativesdk"